summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrédéric-Emmanuel Picca <picca@debian.org>2019-05-27 10:08:01 +0200
committerFrédéric-Emmanuel Picca <picca@debian.org>2019-05-27 10:08:01 +0200
commit3ca57aa72b39b72ae1c6ec18da087d19aa821162 (patch)
tree3e5def3d4832c210295ecfbfef639e7a0c2bac0b
parent8d9e90a57446471df9c568c998aa53cc0e141ac5 (diff)
refresh patch queue
-rw-r--r--debian/patches/0001-do-not-touch-PYTHONPATH.patch4
-rw-r--r--debian/patches/0002-fix-the-install_requires-depends.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/debian/patches/0001-do-not-touch-PYTHONPATH.patch b/debian/patches/0001-do-not-touch-PYTHONPATH.patch
index 298bbe9..0c1c8d0 100644
--- a/debian/patches/0001-do-not-touch-PYTHONPATH.patch
+++ b/debian/patches/0001-do-not-touch-PYTHONPATH.patch
@@ -7,10 +7,10 @@ Subject: wip
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 767aa83..ae6dc12 100644
+index 491c417..bc165cb 100644
--- a/setup.py
+++ b/setup.py
-@@ -256,7 +256,7 @@ class BuildMan(Command):
+@@ -264,7 +264,7 @@ class BuildMan(Command):
path.insert(0, os.path.abspath(build.build_lib))
env = dict((str(k), str(v)) for k, v in os.environ.items())
diff --git a/debian/patches/0002-fix-the-install_requires-depends.patch b/debian/patches/0002-fix-the-install_requires-depends.patch
index b999cad..2ea8512 100644
--- a/debian/patches/0002-fix-the-install_requires-depends.patch
+++ b/debian/patches/0002-fix-the-install_requires-depends.patch
@@ -1,4 +1,4 @@
-From: =?utf-8?q?Picca_Fr=C3=83=C2=A9d=C3=83=C2=A9ric-Emmanuel?=
+From: =?utf-8?b?UGljY2EgRnLDg8KpZMODwqlyaWMtRW1tYW51ZWw=?=
<picca@synchrotron-soleil.fr>
Date: Thu, 7 Sep 2017 14:33:43 +0200
Subject: fix the install_requires depends
@@ -8,12 +8,12 @@ Subject: fix the install_requires depends
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index ae6dc12..abe7442 100644
+index bc165cb..8b0dcb2 100644
--- a/setup.py
+++ b/setup.py
-@@ -864,7 +864,15 @@ def get_project_configuration(dry_run):
+@@ -963,7 +963,15 @@ def get_project_configuration(dry_run):
# for most of the computation
- "numpy",
+ "numpy%s" % numpy_requested_version,
# for the script launcher
- "setuptools"]
+ "setuptools",
@@ -26,5 +26,5 @@ index ae6dc12..abe7442 100644
+ "six"
+ ]
- setup_requires = ["setuptools", "numpy", "cython"]
+ setup_requires = ["setuptools", "numpy"]