summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/clean1
-rw-r--r--debian/compat2
-rw-r--r--debian/control30
-rw-r--r--debian/copyright2
-rw-r--r--debian/gbp.conf9
-rw-r--r--debian/patches/distribute.patch13
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules5
9 files changed, 42 insertions, 28 deletions
diff --git a/debian/changelog b/debian/changelog
index eeccb82..22d49e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-fswrap (1.0.1-0.1) UNRELEASED; urgency=medium
+
+ * Non-maintainer upload.
+ * New upstream version.
+
+ -- Andrew Shadura <andrewsh@debian.org> Mon, 31 Jul 2017 07:58:55 -0400
+
python-fswrap (0.1.1-1.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..45149aa
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+*.egg-info/*
diff --git a/debian/compat b/debian/compat
index 45a4fb7..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-8
+9
diff --git a/debian/control b/debian/control
index 6809312..785f6ff 100644
--- a/debian/control
+++ b/debian/control
@@ -2,17 +2,37 @@ Source: python-fswrap
Section: python
Priority: extra
Maintainer: Julien Danjou <acid@debian.org>
-Build-Depends: debhelper (>= 8.0.0), python-all,
- python-setuptools, python-pkg-resources, python-nose
-Standards-Version: 3.9.4
-Homepage: https://github.com/lakshmivyas/fswrap
+Build-Depends: debhelper (>= 9),
+ python-all,
+ python-nose,
+ python-pkg-resources,
+ python-setuptools,
+ python3-all,
+ python3-nose,
+ python3-pkg-resources,
+ python3-setuptools
+Standards-Version: 4.0.0
+Homepage: https://github.com/hyde/fswrap
Vcs-Git: git://git.debian.org/collab-maint/python-fswrap.git
Vcs-Browser: http://git.debian.org/?p=collab-maint/python-fswrap.git;a=summary
Package: python-fswrap
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
-Description: Unified object oriented interface for interacting with file system objects
+Provides: ${python:Provides}
+Description: unified object oriented interface to file system objects
File system operations in Python are distributed across modules: os,
os.path, fnmatch, shutil and distutils. This module attempts to make the
right choices for common operations to provide a single interface.
+ .
+ This package is for Python 2.
+
+Package: python3-fswrap
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: unified object oriented interface to file system objects (Python 3)
+ File system operations in Python are distributed across modules: os,
+ os.path, fnmatch, shutil and distutils. This module attempts to make the
+ right choices for common operations to provide a single interface.
+ .
+ This package is for Python 3.
diff --git a/debian/copyright b/debian/copyright
index 1c391ca..e58565b 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -3,7 +3,7 @@ Upstream-Name: python-fswrap
Source: https://github.com/lakshmivyas/fswrap
Files: *
-Copyright: 2012 Lakshmi Vyasarajan, Ringce.com
+Copyright: 2012—2015 Lakshmi Vyasarajan, Ringce.com
License: MIT
Files: debian/*
diff --git a/debian/gbp.conf b/debian/gbp.conf
index cfff8c1..47a5c12 100644
--- a/debian/gbp.conf
+++ b/debian/gbp.conf
@@ -1,8 +1,5 @@
-[git-buildpackage]
-debian-branch = debian/unstable
+[DEFAULT]
+debian-branch = debian/master
+upstream-branch = upstream/master
pristine-tar = True
-
-[git-import-orig]
-debian-branch = debian/unstable
sign-tags = True
-pristine-tar = True
diff --git a/debian/patches/distribute.patch b/debian/patches/distribute.patch
deleted file mode 100644
index bafead3..0000000
--- a/debian/patches/distribute.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Description: Do not download distribute from the internet
-Author: Sebastian Ramacher <sramacher@debian.org>
-Bug-Debian: http://bugs.debian.org/735825
-Last-Update: 2014-02-05
-
---- python-fswrap-0.1.1.orig/setup.py
-+++ python-fswrap-0.1.1/setup.py
-@@ -1,5 +1,3 @@
--from distribute_setup import use_setuptools
--use_setuptools()
- from setuptools import setup
-
- try:
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index fc1cc3b..0000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-distribute.patch
diff --git a/debian/rules b/debian/rules
index 9f1a88b..941b5ad 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,10 @@
#!/usr/bin/make -f
# -*- makefile -*-
+
+export PYBUILD_NAME=fswrap
+
%:
- dh $@ --with python2
+ dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_auto_test:
python setup.py test