summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovico Cavedon <ludovico.cavedon@gmail.com>2009-10-21 00:17:37 -0700
committerLudovico Cavedon <ludovico.cavedon@gmail.com>2009-10-21 00:17:37 -0700
commitec07c9dfb6dbbc1bcc1b46be0b8fc68d844a2616 (patch)
tree42a9020623d8eba4827a75610bc4c11e10664623
parenteb213dc0b5bbc08dc6a5ee68fe2b92bf9b755db3 (diff)
use cdbs
update control file with more accurate dependencies and descriptions update changelog
-rw-r--r--debian/changelog2
-rw-r--r--debian/control46
-rwxr-xr-xdebian/rules45
3 files changed, 39 insertions, 54 deletions
diff --git a/debian/changelog b/debian/changelog
index c3adfa1..0787bd9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,4 +2,4 @@ python-iniparse (0.3.1-1) unstable; urgency=low
* Initial release (Closes: #506011)
- -- Joao Eriberto Mota Filho <eriberto@eriberto.pro.br> Wed, 29 Jul 2009 10:03:26 -0300
+ -- Ludovico Cavedon <ludovico.cavedon@gmail.com> Wed, 21 Oct 2009 00:15:38 -0700
diff --git a/debian/control b/debian/control
index bdc8014..542cb16 100644
--- a/debian/control
+++ b/debian/control
@@ -1,21 +1,37 @@
Source: python-iniparse
Section: python
-Priority: optional
-Maintainer: Joao Eriberto Mota Filho <eriberto@eriberto.pro.br>
-Build-Depends: debhelper (>= 7), python
-Build-Depends-Indep: python-support
-Standards-Version: 3.8.2
-Homepage: http://code.google.com/p/iniparse
-Vcs-Svn: svn://svn.debian.org/svn/debian-br-team/packages/python-iniparse
-Vcs-Browser: http://svn.debian.org/wsvn/debian-br-team/packages/python-iniparse
+Priority: extra
+Maintainer: Ludovico Cavedon <ludovico.cavedon@gmail.com>
+Build-Depends: debhelper (>= 7), cdbs
+Build-Depends-Indep: python-support (>= 0.5.3)
+Standards-Version: 3.8.3
+Homepage: http://code.google.com/p/iniparse/
+Vcs-Git: git://git.debian.org/git/collab-maint/python-iniparse.git
+Vcs-Browser: http://git.debian.org/?p=collab-maint/python-iniparse.git
+XS-Python-Version: >= 2.4
Package: python-iniparse
Architecture: all
-Depends: ${python:Depends}, ${python:Versions}, ${python:Provides}
-Description: module to access and modify configuration data in ini files
- iniparse is an INI parser for Python which is API compatible with the
- standard library's ConfigParser. It preserves structure of INI files
- (order of sections & options, indentation, comments and blank lines
- are preserved when data is updated).
+Depends: ${python:Depends}, ${misc:Depends}
+Provides: ${python:Provides}
+XB-Python-Version: >= ${python:Versions}
+Description: Module to access and modify configuration data in INI files
+ iniparse is a INI parser for Python which is:
.
- Usage examples: http://code.google.com/p/iniparse/wiki/UsageExamples
+ * Compatiable with ConfigParser: Backward compatible implementations of
+ ConfigParser, RawConfigParser, and SafeConfigParser are included that are
+ API-compatible with the Python standard library. They pass all the unit tests
+ in Python-2.4.4.
+ .
+ * Preserves structure of INI files: Order of sections & options, indentation,
+ comments, and blank lines are preserved as far as possible when data is
+ updated.
+ .
+ * More convenient: Values can be accessed using dotted notation
+ (cfg.user.name), or using container syntax (cfg['user']['name']).
+ .
+ It is very useful for config files that are updated both by users and by
+ programs, since it is very disorienting for a user to have her config file
+ completely rearranged whenever a program changes it. iniparse also allows
+ making the order of entries in a config file significant, which is desirable
+ in applications like image galleries.
diff --git a/debian/rules b/debian/rules
index 9f81d5f..9e5df29 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,42 +1,11 @@
#!/usr/bin/make -f
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+DEB_PYTHON_SYSTEM=pysupport
-PROG_NAME=iniparse
+# Debhelper must be included before python-distutils to use
+# dh_python / dh_pycentral / dh_pysupport
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
-build: build-stamp
-build-stamp:
- dh_testdir
- python setup.py build
- touch build-stamp $(PROG_NAME)/__init__.py
-
-clean:
- dh_testdir
- dh_testroot
- python setup.py clean --all
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_prep
- python setup.py install --root=debian/python-$(PROG_NAME)
- rm -rf debian/python-$(PROG_NAME)/usr/share/doc/$(PROG_NAME)-*
-
-binary: binary-indep
-binary-arch:
-binary-indep: install
- dh_testdir
- dh_testroot
- dh_installdocs html
- dh_installchangelogs
- dh_compress
- dh_fixperms
- dh_pysupport
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-.PHONY: build clean binary-indep binary-arch binary install
+# If your package provides eggs, install egg-info directories instead of real eggs
+# DEB_PYTHON_INSTALL_ARGS_ALL += --single-version-externally-managed