summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Prescott <stuart@debian.org>2019-12-22 11:21:34 +1100
committerStuart Prescott <stuart@debian.org>2019-12-22 11:35:25 +1100
commit1bb6c4f68628d529a079e655e1d59ea17748c581 (patch)
treedebd713c3cc51b9fbd73da655fde298b7a13ddaa
parenta5cc300bd36ee6ddf01502aee082f6e9678f310f (diff)
Drop Python 2 package
-rw-r--r--debian/control31
-rw-r--r--debian/doc-base4
-rwxr-xr-xdebian/rules3
3 files changed, 3 insertions, 35 deletions
diff --git a/debian/control b/debian/control
index df1114c..5216fd2 100644
--- a/debian/control
+++ b/debian/control
@@ -4,9 +4,6 @@ Priority: optional
Maintainer: Ludovico Cavedon <cavedon@debian.org>
Build-Depends: debhelper (>= 9),
dh-python,
- python-all,
- python-setuptools,
- python-six,
python3-all,
python3-setuptools,
python3-six
@@ -15,34 +12,6 @@ Homepage: http://code.google.com/p/iniparse/
Vcs-Git: https://salsa.debian.org/debian/python-iniparse.git
Vcs-Browser: https://salsa.debian.org/debian/python-iniparse
-Package: python-iniparse
-Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python-six
-Provides: ${python:Provides}
-Breaks: ${python:Breaks}
-Description: access and modify configuration data in INI files (Python 2)
- iniparse is a INI parser for Python which is:
- .
- * Compatible with ConfigParser: Backward compatible implementations of
- ConfigParser, RawConfigParser, and SafeConfigParser are included that are
- API-compatible with the Python standard library. They pass all the unit
- tests in Python-2.4.4.
- .
- * Preserves structure of INI files: Order of sections & options, indentation,
- comments, and blank lines are preserved as far as possible when data is
- updated.
- .
- * More convenient: Values can be accessed using dotted notation
- (cfg.user.name), or using container syntax (cfg['user']['name']).
- .
- It is very useful for config files that are updated both by users and by
- programs, since it is very disorienting for a user to have her config file
- completely rearranged whenever a program changes it. iniparse also allows
- making the order of entries in a config file significant, which is desirable
- in applications like image galleries.
- .
- This is a Python 2 version of the package
-
Package: python3-iniparse
Architecture: all
Depends: ${misc:Depends}, ${python3:Depends}, python3-six
diff --git a/debian/doc-base b/debian/doc-base
index caf538d..3a0d6bd 100644
--- a/debian/doc-base
+++ b/debian/doc-base
@@ -3,7 +3,7 @@ Title: Python Iniparse documentation
Section: Programming
Format: HTML
-Index: /usr/share/doc/python-iniparse/html/index.html
-Files: /usr/share/doc/python-iniparse/html/*
+Index: /usr/share/doc/python3-iniparse/html/index.html
+Files: /usr/share/doc/python3-iniparse/html/*
diff --git a/debian/rules b/debian/rules
index e37b8f1..f21f4f3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,14 +3,13 @@
export PYBUILD_NAME=iniparse
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install
rm -fr debian/python*-iniparse/usr/share/doc/iniparse-*
override_dh_auto_test:
- python2 ./runtests.py
python3 ./runtests.py
.PHONY: override_dh_auto_install override_dh_auto_test