summaryrefslogtreecommitdiff
path: root/python-iniparse.spec
diff options
context:
space:
mode:
authorLudovico Cavedon <ludovico.cavedon@gmail.com>2009-10-20 23:52:30 -0700
committerLudovico Cavedon <ludovico.cavedon@gmail.com>2009-10-20 23:52:30 -0700
commit8cbb16c4830d341deb19d77d8ff9c10813460e46 (patch)
treecf55736336137013468fc6a4a3add54e74f45f74 /python-iniparse.spec
Imported Upstream version 0.3.1
Diffstat (limited to 'python-iniparse.spec')
-rw-r--r--python-iniparse.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-iniparse.spec b/python-iniparse.spec
new file mode 100644
index 0000000..8ebd41f
--- /dev/null
+++ b/python-iniparse.spec
@@ -0,0 +1,72 @@
+%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+Name: python-iniparse
+Version: 0.3.1
+Release: 1%{?dist}
+Summary: Python Module for Accessing and Modifying Configuration Data in INI files
+Group: Development/Libraries
+License: MIT
+URL: http://code.google.com/p/iniparse/
+Source0: http://iniparse.googlecode.com/files/iniparse-%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+BuildRequires: python-setuptools
+
+BuildArch: noarch
+
+%description
+iniparse is an INI parser for Python which is API compatible
+with the standard library's ConfigParser, preserves structure of INI
+files (order of sections & options, indentation, comments, and blank
+lines are preserved when data is updated), and is more convenient to
+use.
+
+%prep
+%setup -q -n iniparse-%{version}
+
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
+# fixes
+chmod 644 $RPM_BUILD_ROOT//usr/share/doc/iniparse-%{version}/index.html
+mv $RPM_BUILD_ROOT/usr/share/doc/iniparse-%{version} $RPM_BUILD_ROOT/usr/share/doc/python-iniparse-%{version}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{_docdir}/python-iniparse-%{version}/*
+%{python_sitelib}/iniparse
+%{python_sitelib}/iniparse-%{version}-py*.egg-info
+
+
+
+%changelog
+* Mon Mar 2 2009 Paramjit Oberoi <param@cs.wisc.edu> - 0.3.1-1
+- Release 0.3.1
+* Fri Feb 27 2009 Paramjit Oberoi <param@cs.wisc.edu> - 0.3.0-1
+- Release 0.3.0
+* Tue Dec 6 2008 Paramjit Oberoi <param@cs.wisc.edu> - 0.2.4-1
+- Release 0.2.4
+- added egg-info file to %%files
+* Tue Dec 11 2007 Paramjit Oberoi <param@cs.wisc.edu> - 0.2.3-1
+- Release 0.2.3
+* Tue Sep 24 2007 Paramjit Oberoi <param@cs.wisc.edu> - 0.2.2-1
+- Release 0.2.2
+* Tue Aug 7 2007 Paramjit Oberoi <param@cs.wisc.edu> - 0.2.1-1
+- Release 0.2.1
+* Fri Jul 27 2007 Tim Lauridsen <timlau@fedoraproject.org> - 0.2-3
+- relocated doc to %{_docdir}/python-iniparse-%{version}
+* Thu Jul 26 2007 Tim Lauridsen <timlau@fedoraproject.org> - 0.2-2
+- changed name from iniparse to python-iniparse
+* Tue Jul 17 2007 Tim Lauridsen <timlau@fedoraproject.org> - 0.2-1
+- Release 0.2
+- Added html/* to %%doc
+* Fri Jul 13 2007 Tim Lauridsen <timlau@fedoraproject.org> - 0.1-1
+- Initial build.