summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control41
1 files changed, 38 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 5377fff..52ddb33 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,14 @@ Source: python-iniparse
Section: python
Priority: extra
Maintainer: Ludovico Cavedon <cavedon@debian.org>
-Build-Depends: debhelper (>= 8), python
+Build-Depends: debhelper (>= 9),
+ dh-python,
+ python-all,
+ python-setuptools,
+ python-six,
+ python3-all,
+ python3-setuptools,
+ python3-six
Standards-Version: 3.9.1
Homepage: http://code.google.com/p/iniparse/
Vcs-Git: git://git.debian.org/git/collab-maint/python-iniparse.git
@@ -11,10 +18,10 @@ X-Python-Version: >= 2.4
Package: python-iniparse
Architecture: all
-Depends: ${python:Depends}, ${misc:Depends}
+Depends: ${misc:Depends}, ${python:Depends}, python-six
Provides: ${python:Provides}
Breaks: ${python:Breaks}
-Description: Module to access and modify configuration data in INI files
+Description: access and modify configuration data in INI files (Python 2)
iniparse is a INI parser for Python which is:
.
* Compatible with ConfigParser: Backward compatible implementations of
@@ -34,3 +41,31 @@ Description: Module to access and modify configuration data in INI files
completely rearranged whenever a program changes it. iniparse also allows
making the order of entries in a config file significant, which is desirable
in applications like image galleries.
+ .
+ This is a Python 2 version of the package
+
+Package: python3-iniparse
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}, python3-six
+Description: access and modify configuration data in INI files (Python 3)
+ iniparse is a INI parser for Python which is:
+ .
+ * Compatible with ConfigParser: Backward compatible implementations of
+ ConfigParser, RawConfigParser, and SafeConfigParser are included that are
+ API-compatible with the Python standard library. They pass all the unit
+ tests in Python-2.4.4.
+ .
+ * Preserves structure of INI files: Order of sections & options, indentation,
+ comments, and blank lines are preserved as far as possible when data is
+ updated.
+ .
+ * More convenient: Values can be accessed using dotted notation
+ (cfg.user.name), or using container syntax (cfg['user']['name']).
+ .
+ It is very useful for config files that are updated both by users and by
+ programs, since it is very disorienting for a user to have her config file
+ completely rearranged whenever a program changes it. iniparse also allows
+ making the order of entries in a config file significant, which is desirable
+ in applications like image galleries.
+ .
+ This is a Python 3 version of the package