summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefano Rivera <stefanor@debian.org>2021-05-21 16:27:35 -0400
committerStefano Rivera <stefanor@debian.org>2021-05-21 16:35:39 -0400
commit85f33465c05e814d100718a526956141a9e19c8f (patch)
tree713d5f35c1091a0869dbd4f1716c5576a660d6fb
parent2cf4f26d5969ac40a24506f95d3d301fbc4c0bc0 (diff)
Patch: Fix crypto_kdf_derive_from_key() on 32-bit platforms. (Closes: #988102)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/32bit-kdf.patch24
-rw-r--r--debian/patches/series1
3 files changed, 32 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 251afe9..1c87369 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-libnacl (1.7.2-3) UNRELEASED; urgency=medium
+
+ * Patch: Fix crypto_kdf_derive_from_key() on 32-bit platforms.
+ (Closes: #988102)
+
+ -- Stefano Rivera <stefanor@debian.org> Fri, 21 May 2021 16:26:59 -0400
+
python-libnacl (1.7.2-2) unstable; urgency=medium
* Add Breaks: python3-duniterpy (<< 0.60.1) (see #974655).
diff --git a/debian/patches/32bit-kdf.patch b/debian/patches/32bit-kdf.patch
new file mode 100644
index 0000000..fc3183c
--- /dev/null
+++ b/debian/patches/32bit-kdf.patch
@@ -0,0 +1,24 @@
+From: =?utf-8?b?TWljaGHFgiBHw7Nybnk=?= <mgorny@gentoo.org>
+Date: Fri, 21 May 2021 16:25:27 -0400
+Subject: Fix crypto_kdf_derive_from_key() on 32-bit platforms
+
+Bug-Upstream: https://github.com/saltstack/libnacl/issues/126
+Bug-Debian: https://bugs.debian.org/988102
+Forwarded: https://github.com/saltstack/libnacl/pull/130
+---
+ libnacl/__init__.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libnacl/__init__.py b/libnacl/__init__.py
+index 98a53d9..f799b23 100644
+--- a/libnacl/__init__.py
++++ b/libnacl/__init__.py
+@@ -1195,7 +1195,7 @@ def crypto_kdf_derive_from_key(subkey_size, subkey_id, context, master_key):
+ """
+ size = int(subkey_size)
+ buf = ctypes.create_string_buffer(size)
+- nacl.crypto_kdf_derive_from_key(buf, subkey_size, subkey_id, context, master_key)
++ nacl.crypto_kdf_derive_from_key(buf, subkey_size, ctypes.c_ulonglong(subkey_id), context, master_key)
+ return buf.raw
+
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..e81c8d4
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+32bit-kdf.patch