summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 0 insertions, 36 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100644
index 79dda9c..0000000
--- a/setup.py
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/usr/bin/env python
-# -*- coding: utf-8 -*-
-
-from setuptools import setup
-
-NAME = "libnacl"
-DESC = "Python bindings for libsodium based on ctypes"
-
-# Version info -- read without importing
-_locals = {}
-with open("libnacl/version.py") as fp:
- exec(fp.read(), None, _locals)
-VERSION = _locals["version"]
-
-setup(
- name=NAME,
- version=VERSION,
- description=DESC,
- author="Thomas S Hatch",
- author_email="thatch@saltstack.com",
- url="https://libnacl.readthedocs.org/",
- classifiers=[
- "Operating System :: OS Independent",
- "License :: OSI Approved :: Apache Software License",
- "Programming Language :: Python",
- "Programming Language :: Python :: 2.6",
- "Programming Language :: Python :: 2.7",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Development Status :: 5 - Production/Stable",
- "Intended Audience :: Developers",
- "Topic :: Security :: Cryptography",
- ],
- packages=["libnacl"],
-)