summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2018-04-30 15:42:37 +0200
committerAndrew Shadura <andrewsh@debian.org>2018-04-30 16:00:44 +0200
commitbf663011e730c6a0b1565de62b4eed21e87d69a9 (patch)
treedffd0aa34ab59aaa9dc252e51460c57609285a17
parent01e7e1ef9084fed964df7c2c6f9cdc056fd0bdbd (diff)
Build Python 3 packages
-rw-r--r--debian/control19
l---------debian/docs1
-rw-r--r--debian/python-ofxclient.docs (renamed from debian/python-ofxparse.docs)0
-rw-r--r--debian/python3-ofxclient.docs (renamed from debian/python3-ofxparse.docs)0
-rwxr-xr-xdebian/rules4
5 files changed, 19 insertions, 5 deletions
diff --git a/debian/control b/debian/control
index cf84b0a..ea88641 100644
--- a/debian/control
+++ b/debian/control
@@ -5,17 +5,32 @@ Maintainer: Debian QA Group <packages@qa.debian.org>
Build-Depends: debhelper (>= 9)
, dh-python
, python-all (>= 2.7~)
+ , python3-all
, python-setuptools
+ , python3-setuptools
, python-argparse
, python-beautifulsoup (>= 3.0)
+ , python3-beautifulsoup (>= 3.0)
, python-keyring
+ , python3-keyring
, python-ofxparse (>= 0.8)
+ , python3-ofxparse (>= 0.8)
Standards-Version: 3.9.8
Homepage: https://sites.google.com/site/ofxparse/
-X-Python-Version: >= 2.6
+X-Python-Version: >= 2.7
Package: python-ofxclient
Architecture: all
Depends: ${python:Depends}, ${misc:Depends}
-Description: OFX client for dowloading transactions from banks
+Description: OFX client for dowloading transactions from banks (Python 2.7)
Simple ofxclient command line utility and OFX client libraries for development.
+ .
+ This package is for Python 2.7.
+
+Package: python3-ofxclient
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: OFX client for dowloading transactions from banks (Python 3)
+ Simple ofxclient command line utility and OFX client libraries for development.
+ .
+ This package is for Python 3.
diff --git a/debian/docs b/debian/docs
deleted file mode 120000
index 0f6c4cf..0000000
--- a/debian/docs
+++ /dev/null
@@ -1 +0,0 @@
-python-ofxparse.docs \ No newline at end of file
diff --git a/debian/python-ofxparse.docs b/debian/python-ofxclient.docs
index b43bf86..b43bf86 100644
--- a/debian/python-ofxparse.docs
+++ b/debian/python-ofxclient.docs
diff --git a/debian/python3-ofxparse.docs b/debian/python3-ofxclient.docs
index b43bf86..b43bf86 100644
--- a/debian/python3-ofxparse.docs
+++ b/debian/python3-ofxclient.docs
diff --git a/debian/rules b/debian/rules
index 495db8b..fbaff64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,8 +3,8 @@
#export DH_VERBOSE=1
export PYBUILD_NAME=ofxclient
-export PYBUILD_DISABLE=test
+#export PYBUILD_DISABLE=test
%:
- dh $@ --with python2 --buildsystem=pybuild
+ dh $@ --with python2,python3 --buildsystem=pybuild