summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrej Shadura <andrewsh@debian.org>2018-04-30 11:09:55 +0200
committerAndrej Shadura <andrewsh@debian.org>2018-04-30 11:09:55 +0200
commitf3522f9e425dd9e6c8bd395febed9f407e4c3f10 (patch)
treef31d33921a2d12309b69e61fb66400aef9866d9c /debian
parent36236df28b6c3dc2284d254c4e92dfbeacc1b78b (diff)
Support Python 3
Diffstat (limited to 'debian')
-rw-r--r--debian/control26
-rw-r--r--debian/python-ofxhome.docs (renamed from debian/python-ofxparse.docs)0
-rw-r--r--debian/python3-ofxhome.docs (renamed from debian/python3-ofxparse.docs)0
-rwxr-xr-xdebian/rules2
4 files changed, 25 insertions, 3 deletions
diff --git a/debian/control b/debian/control
index 8a38ec4..7a21ae6 100644
--- a/debian/control
+++ b/debian/control
@@ -5,15 +5,17 @@ Maintainer: Debian QA Group <packages@qa.debian.org>
Build-Depends: debhelper (>= 9)
, dh-python
, python-all (>= 2.7~)
+ , python3-all
, python-setuptools
+ , python3-setuptools
Standards-Version: 3.9.8
Homepage: https://github.com/captin411/ofxhome
-X-Python-Version: >= 2.6
+X-Python-Version: >= 2.7
Package: python-ofxhome
Architecture: all
Depends: ${python:Depends}, ${misc:Depends}
-Description: ofxhome.com financial institution lookup REST client
+Description: ofxhome.com financial institution lookup REST client (Python 2.7)
ofxhome is a REST client for the web service provided by ofxhome.com.
.
ofxhome.com provides a way to discover the Open Financial Exchange
@@ -25,3 +27,23 @@ Description: ofxhome.com financial institution lookup REST client
.
This client by itself is not all that useful unless you are coupling
it with software that needs this lookup capability.
+ .
+ This package is for Python 2.7.
+
+Package: python3-ofxhome
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}
+Description: ofxhome.com financial institution lookup REST client (Python 3)
+ ofxhome is a REST client for the web service provided by ofxhome.com.
+ .
+ ofxhome.com provides a way to discover the Open Financial Exchange
+ (OFX) URLs and financial institution IDs for banks and other
+ financial institutions.
+ .
+ ofxhome is a sort of "DNS" for financial institution OFX URLs and
+ IDs.
+ .
+ This client by itself is not all that useful unless you are coupling
+ it with software that needs this lookup capability.
+ .
+ This package is for Python 3.
diff --git a/debian/python-ofxparse.docs b/debian/python-ofxhome.docs
index e845566..e845566 100644
--- a/debian/python-ofxparse.docs
+++ b/debian/python-ofxhome.docs
diff --git a/debian/python3-ofxparse.docs b/debian/python3-ofxhome.docs
index e845566..e845566 100644
--- a/debian/python3-ofxparse.docs
+++ b/debian/python3-ofxhome.docs
diff --git a/debian/rules b/debian/rules
index 59d5e7d..9bc049a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,4 +6,4 @@ export PYBUILD_NAME=ofxhome
%:
- dh $@ --with python2 --buildsystem=pybuild
+ dh $@ --with python2,python3 --buildsystem=pybuild