summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2016-03-13 22:06:22 -0400
committerAndrew Shadura <andrewsh@debian.org>2016-10-19 17:56:53 +0200
commitd5aaaff314bcd2121666880868aa53a8f858dfbd (patch)
tree3c39bfe63fde1f3255c6f586194d7616d9f7442d /debian
parent48f73f7fc980eb923bf453e175dfd6c128c48063 (diff)
Imported Debian patch 0.14-2
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control4
-rw-r--r--debian/patches/explicit-lxml13
-rw-r--r--debian/patches/series1
4 files changed, 24 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index f40cae1..e07feba 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+python-ofxparse (0.14-2) unstable; urgency=medium
+
+ * Tell BeautifulSoup to use lxml explicitly. "Patch"
+ from Jelmer Vernooij. closes: #818132.
+ * Orphan the package.
+
+ -- Clint Adams <clint@debian.org> Sun, 13 Mar 2016 22:06:22 -0400
+
python-ofxparse (0.14-1) unstable; urgency=low
* Initial release.
diff --git a/debian/control b/debian/control
index 08a8b11..b0cf40a 100644
--- a/debian/control
+++ b/debian/control
@@ -1,7 +1,7 @@
Source: python-ofxparse
Section: python
Priority: optional
-Maintainer: Clint Adams <clint@debian.org>
+Maintainer: Debian QA Group <packages@qa.debian.org>
Build-Depends: debhelper (>= 9)
, dh-python
, python-all (>= 2.7~)
@@ -12,7 +12,7 @@ Build-Depends: debhelper (>= 9)
, python3-six
, python-bs4
, python3-bs4
-Standards-Version: 3.9.5
+Standards-Version: 3.9.7
Homepage: https://sites.google.com/site/ofxparse/
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.2
diff --git a/debian/patches/explicit-lxml b/debian/patches/explicit-lxml
new file mode 100644
index 0000000..aabab28
--- /dev/null
+++ b/debian/patches/explicit-lxml
@@ -0,0 +1,13 @@
+bug#818132
+
+--- a/ofxparse/ofxparse.py
++++ b/ofxparse/ofxparse.py
+@@ -28,7 +28,7 @@
+ return BeautifulSoup(fh)
+ except ImportError:
+ from BeautifulSoup import BeautifulStoneSoup
+- return BeautifulStoneSoup(fh)
++ return BeautifulStoneSoup(fh, "lxml")
+
+
+ def try_decode(string, encoding):
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ae721d3
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+explicit-lxml