summaryrefslogtreecommitdiff
path: root/ofxparse.egg-info
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-10-19 18:02:05 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-10-19 18:02:05 +0200
commitd8216aeb9c12ea81d9941edc6eff39be32c24aca (patch)
tree1ad1a1dd693ba915dcda076adf037964c9d6132f /ofxparse.egg-info
parentbdbd753fe4ab2de979939bae4caf93b16f6b5efc (diff)
Imported Upstream version 0.15
Diffstat (limited to 'ofxparse.egg-info')
-rw-r--r--ofxparse.egg-info/PKG-INFO48
-rw-r--r--ofxparse.egg-info/SOURCES.txt6
-rw-r--r--ofxparse.egg-info/requires.txt4
3 files changed, 44 insertions, 14 deletions
diff --git a/ofxparse.egg-info/PKG-INFO b/ofxparse.egg-info/PKG-INFO
index 83be6d8..c19dfd2 100644
--- a/ofxparse.egg-info/PKG-INFO
+++ b/ofxparse.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: ofxparse
-Version: 0.14
+Version: 0.15
Summary: Tools for working with the OFX (Open Financial Exchange) file format
Home-page: http://sites.google.com/site/ofxparse
Author: Jerry Seutter
@@ -23,11 +23,13 @@ Description: ofxparse
Example Usage
=============
- Here's a sample program::
+ Here's a sample program
- from ofxparse import OfxParser
+ .. code:: python
- ofx = OfxParser.parse(file('file.ofx'))
+ from ofxparse import OfxParser
+ with codecs.open('file.ofx') as fileobj:
+ ofx = OfxParser.parse(fileobj)
ofx.accounts # An account with information
ofx.account.number # The account number
ofx.account.routing_number # The transit id (sometimes called branch number)
@@ -41,7 +43,8 @@ Description: ofxparse
Help!
=====
- Sample .ofx files are very useful. If you want to help us out, please edit
+ Sample ``.ofx`` and ``.qfx`` files are very useful.
+ If you want to help us out, please edit
all identifying information from the file and then email it to jseutter dot
ofxparse at gmail dot com.
@@ -49,25 +52,46 @@ Description: ofxparse
===========
Prerequisites::
- (Ubuntu) sudo apt-get install python-beautifulsoup python-nose python-coverage-test-runner
- (pip) pip install BeautifulSoup nose coverage
+ # Ubuntu
+ sudo apt-get install python-beautifulsoup python-nose python-coverage-test-runner
+
+ # pip for Python 3:
+ pip install BeautifulSoup4 six lxml nose coverage
+
+ # pip for Python 2:
+ pip install BeautifulSoup six nose coverage
+
+ Tests:
+ Simply running the ``nosetests`` command should run the tests.
- Tests::
- Simply running the "nose" command should run the tests. If you don't have nose
- installed, the following might also work:
+ .. code:: bash
+
+ nosetests
+
+ If you don't have nose installed, the following might also work:
+
+ .. code:: bash
python -m unittest tests.test_parse
- Test Coverage Report::
+ Test Coverage Report:
+
+ .. code:: bash
coverage run -m unittest tests.test_parse
+
+ # text report
+ coverage report
+
+ # html report
coverage html
firefox htmlcov/index.html
Homepage
========
- http://sites.google.com/site/ofxparse
+ | Homepage: https://sites.google.com/site/ofxparse
+ | Source: https://github.com/jseutter/ofxparse
License
=======
diff --git a/ofxparse.egg-info/SOURCES.txt b/ofxparse.egg-info/SOURCES.txt
index 6cff2c7..21fc7ff 100644
--- a/ofxparse.egg-info/SOURCES.txt
+++ b/ofxparse.egg-info/SOURCES.txt
@@ -1,12 +1,13 @@
AUTHORS
LICENSE
MANIFEST.in
-README
+README.rst
setup.cfg
setup.py
ofxparse/__init__.py
ofxparse/mcc.py
ofxparse/ofxparse.py
+ofxparse/ofxprinter.py
ofxparse/ofxutil.py
ofxparse.egg-info/PKG-INFO
ofxparse.egg-info/SOURCES.txt
@@ -24,13 +25,16 @@ tests/fixtures/bank_medium.ofx
tests/fixtures/bank_small.ofx
tests/fixtures/checking.ofx
tests/fixtures/fidelity.ofx
+tests/fixtures/investment_401k.ofx
tests/fixtures/investment_medium.ofx
tests/fixtures/multiple_accounts.ofx
tests/fixtures/multiple_accounts2.ofx
tests/fixtures/signon_fail.ofx
tests/fixtures/signon_success.ofx
tests/fixtures/signon_success_no_message.ofx
+tests/fixtures/suncorp.ofx
tests/fixtures/vanguard.ofx
+tests/fixtures/vanguard401k.ofx
tests/fixtures/fail_nice/date_missing.ofx
tests/fixtures/fail_nice/decimal_error.ofx
tests/fixtures/fail_nice/empty_balance.ofx \ No newline at end of file
diff --git a/ofxparse.egg-info/requires.txt b/ofxparse.egg-info/requires.txt
index d33d9e5..c038268 100644
--- a/ofxparse.egg-info/requires.txt
+++ b/ofxparse.egg-info/requires.txt
@@ -1,2 +1,4 @@
beautifulsoup4
-six \ No newline at end of file
+lxml
+six
+lxml