summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2016-10-19 18:02:05 +0200
committerAndrew Shadura <andrewsh@debian.org>2016-10-19 18:02:05 +0200
commitd8216aeb9c12ea81d9941edc6eff39be32c24aca (patch)
tree1ad1a1dd693ba915dcda076adf037964c9d6132f /setup.py
parentbdbd753fe4ab2de979939bae4caf93b16f6b5efc (diff)
Imported Upstream version 0.15
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 14 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8450a12..7ef8b6c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,6 @@
+
+import codecs
+import os
import re
import sys
@@ -10,30 +13,37 @@ VERSION = re.search(r"__version__ = '(.*?)'",
open("ofxparse/__init__.py").read()).group(1)
# Use BeautifulSoup 3 on Python 2.5 and earlier and BeautifulSoup 4 otherwise
-if sys.version_info < (2,6):
+if sys.version_info < (2, 6):
REQUIRES = [
"beautifulSoup>=3.0",
]
else:
REQUIRES = [
- "beautifulsoup4"
+ "beautifulsoup4",
+ "lxml",
]
-if sys.version_info < (2,7):
+if sys.version_info < (2, 7):
REQUIRES.extend([
"ordereddict>=1.1",
])
REQUIRES.extend([
'six',
+ 'lxml'
])
+README = os.path.join(os.path.dirname(__file__), 'README.rst')
+
+with codecs.open(README, encoding='utf8') as f:
+ LONG_DESCRIPTION = f.read()
+
setup_params = dict(
name='ofxparse',
version=VERSION,
description=("Tools for working with the OFX (Open Financial Exchange)"
" file format"),
- long_description=open("./README", "r").read(),
+ long_description=LONG_DESCRIPTION,
# Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
classifiers=[
"Development Status :: 4 - Beta",