summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/explicit-lxml13
-rw-r--r--debian/patches/series1
-rw-r--r--ofxparse/ofxparse.py2
4 files changed, 21 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d06a985..bb5f700 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+python-ofxparse (0.15-3) unstable; urgency=medium
+
+ * Bring the patch for #818132 back, upstream's code is still broken.
+
+ -- Andrew Shadura <andrewsh@debian.org> Wed, 19 Oct 2016 18:40:15 +0200
+
python-ofxparse (0.15-2) unstable; urgency=medium
* Skip failing tests.
diff --git a/debian/patches/explicit-lxml b/debian/patches/explicit-lxml
new file mode 100644
index 0000000..bb49ab3
--- /dev/null
+++ b/debian/patches/explicit-lxml
@@ -0,0 +1,13 @@
+bug#818132
+
+--- a/ofxparse/ofxparse.py
++++ b/ofxparse/ofxparse.py
+@@ -46,7 +46,7 @@
+ skip_headers(fh)
+ try:
+ from bs4 import BeautifulSoup
+- soup = BeautifulSoup(fh, "xml")
++ soup = BeautifulSoup(fh, "lxml")
+ for tag in soup.findAll():
+ tag.name = tag.name.lower()
+ except ImportError:
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ae721d3
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+explicit-lxml
diff --git a/ofxparse/ofxparse.py b/ofxparse/ofxparse.py
index 5686030..af93ae9 100644
--- a/ofxparse/ofxparse.py
+++ b/ofxparse/ofxparse.py
@@ -46,7 +46,7 @@ def soup_maker(fh):
skip_headers(fh)
try:
from bs4 import BeautifulSoup
- soup = BeautifulSoup(fh, "xml")
+ soup = BeautifulSoup(fh, "lxml")
for tag in soup.findAll():
tag.name = tag.name.lower()
except ImportError: