summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/clean1
-rw-r--r--debian/compat1
-rw-r--r--debian/control65
-rw-r--r--debian/copyright29
-rw-r--r--debian/python-priority.docs1
-rw-r--r--debian/python3-priority.docs1
-rwxr-xr-xdebian/rules11
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch4
10 files changed, 119 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..7d5419a
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+python-priority (1.3.0-1) unstable; urgency=low
+
+ * Initial packaging.
+
+ -- Andrej Shadura <andrewsh@debian.org> Sat, 11 Aug 2018 13:00:46 +0200
diff --git a/debian/clean b/debian/clean
new file mode 100644
index 0000000..b5da3ed
--- /dev/null
+++ b/debian/clean
@@ -0,0 +1 @@
+src/priority.egg-info/*
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b4de394
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+11
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..07eb912
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,65 @@
+Source: python-priority
+Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
+Uploaders: Andrej Shadura <andrewsh@debian.org>
+Section: python
+Priority: optional
+Rules-Requires-Root: no
+Build-Depends:
+ debhelper (>= 11),
+ dh-python,
+ python-all (>= 2.6.6-3),
+ python-setuptools (>= 0.6b3),
+ python3-all,
+ python3-setuptools
+Standards-Version: 4.2.0
+Homepage: https://python-hyper.org/priority/
+Vcs-Git: https://git.dgit.debian.org/python-priority
+Vcs-Browser: https://browse.dgit.debian.org/python-priority.git/
+
+Package: python-priority
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}
+Description: pure-Python implementation of the HTTP/2 priority tree (Python 2)
+ Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+ out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients
+ to express a preference for how the server allocates its (limited) resources to
+ the many outstanding HTTP requests that may be running over a single HTTP/2
+ connection.
+ .
+ Specifically, this Python implementation uses a variant of the implementation
+ used in the H2O project. This original implementation is also the
+ inspiration for nghttp2's priority implementation, and generally produces a
+ very clean and even priority stream. The only notable changes from H2O's
+ implementation are small modifications to allow the priority implementation to
+ work cleanly as a separate implementation, rather than being embedded in a
+ HTTP/2 stack directly.
+ .
+ While priority information in HTTP/2 is only a suggestion, rather than an
+ enforceable constraint, where possible servers should respect the priority
+ requests of their clients.
+ .
+ This package is for Python 2.
+
+Package: python3-priority
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: pure-Python implementation of the HTTP/2 priority tree (Python 3)
+ Priority is a pure-Python implementation of the priority logic for HTTP/2, set
+ out in RFC 7540 Section 5.3 (Stream Priority). This logic allows for clients
+ to express a preference for how the server allocates its (limited) resources to
+ the many outstanding HTTP requests that may be running over a single HTTP/2
+ connection.
+ .
+ Specifically, this Python implementation uses a variant of the implementation
+ used in the H2O project. This original implementation is also the
+ inspiration for nghttp2's priority implementation, and generally produces a
+ very clean and even priority stream. The only notable changes from H2O's
+ implementation are small modifications to allow the priority implementation to
+ work cleanly as a separate implementation, rather than being embedded in a
+ HTTP/2 stack directly.
+ .
+ While priority information in HTTP/2 is only a suggestion, rather than an
+ enforceable constraint, where possible servers should respect the priority
+ requests of their clients.
+ .
+ This package is for Python 3.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..f1adc1a
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,29 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Contact: Cory Benfield <cory@lukasa.co.uk>
+
+Files: *
+Copyright: 2015—2017 Cory Benfield <cory@lukasa.co.uk>
+License: Expat
+
+Files: debian/*
+Copyright: 2018 Andrej Shadura <andrewsh@debian.org>
+License: Expat
+
+License: Expat
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/python-priority.docs b/debian/python-priority.docs
new file mode 100644
index 0000000..a1320b1
--- /dev/null
+++ b/debian/python-priority.docs
@@ -0,0 +1 @@
+README.rst
diff --git a/debian/python3-priority.docs b/debian/python3-priority.docs
new file mode 100644
index 0000000..a1320b1
--- /dev/null
+++ b/debian/python3-priority.docs
@@ -0,0 +1 @@
+README.rst
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..96f1de1
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=priority
+
+%:
+ dh $@ --with python2,python3 --buildsystem=pybuild
+
+override_dh_installchangelogs:
+ dh_installchangelogs HISTORY.rst
+
+.PHONY: override_dh_installchangelogs
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..b39d47e
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,4 @@
+# please also check http://pypi.debian.net/priority/watch
+version=3
+opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
+http://pypi.debian.net/priority/priority-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz))) \ No newline at end of file