summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarl Suster <carl@contraflo.ws>2017-01-09 00:59:48 +1100
committerCarl Suster <carl@contraflo.ws>2017-01-09 00:59:48 +1100
commit0ffdb5a6b7669d2d24dbd77b16e9343aa5580de1 (patch)
tree79412dbf84d8368eef81fe69c6f4d855fc5ad225
parent0283097f2923312771d4fd8e6e4e14ffbc509156 (diff)
Build the Python 3 module and drop the Python 2 module (no rdeps).
-rw-r--r--debian/changelog1
-rw-r--r--debian/control12
-rwxr-xr-xdebian/rules2
3 files changed, 9 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index e21f115..5cdb677 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,7 @@ python-pynzb (0.1.0-3) UNRELEASED; urgency=medium
- BSD -> BSD-3-clause.
* Change Vcs to DPMT git repository and use https.
* Change Homepage to GitHub.
+ * Build the Python 3 module and drop the Python 2 module (no rdeps).
-- Carl Suster <carl@contraflo.ws> Mon, 09 Jan 2017 00:37:36 +1100
diff --git a/debian/control b/debian/control
index c2b2708..cec1ef9 100644
--- a/debian/control
+++ b/debian/control
@@ -8,18 +8,18 @@ Priority: optional
Build-Depends:
debhelper (>= 10),
dh-python,
- python-all (>= 2.6.6-3),
- python-setuptools (>= 0.6b3),
+ python3-all,
+ python3-setuptools,
Standards-Version: 3.9.8
Homepage: https://github.com/ericflo/pynzb
Vcs-Git: https://anonscm.debian.org/git/python-modules/packages/python-pynzb.git
Vcs-Browser: https://anonscm.debian.org/git/python-modules/packages/python-pynzb.git
-Package: python-pynzb
+Package: python3-pynzb
Architecture: all
Depends:
- ${misc:Depends}, ${python:Depends},
- python-lxml
+ ${misc:Depends}, ${python3:Depends},
+ python3-lxml
Description: unified API for parsing NZB files from NNTP (Usenet) servers
pynzb is a unified API for parsing NZB files, with several concrete
implementations included.
@@ -37,3 +37,5 @@ Description: unified API for parsing NZB files from NNTP (Usenet) servers
.
Simply import nzb_parser from the pynzb package. It's an instantiated
version of the fastest available parser that your system can support.
+ .
+ This package provides the Python 3 module.
diff --git a/debian/rules b/debian/rules
index ff82054..165398b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,4 +2,4 @@
# export DH_VERBOSE=1
%:
- dh $@ --with python2 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild