summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarl Suster <carl@contraflo.ws>2017-01-11 15:41:22 +1100
committerCarl Suster <carl@contraflo.ws>2017-01-11 15:41:22 +1100
commit05b5a921d7091f0b2ed3a726fb1f362a8c9fdc84 (patch)
treebdac097e0d5e2eac204f96dd831084f98d349724
parent281489c22ed55a550a74f0fac7b0008d57a36a0b (diff)
Call the version of 2to3 corresponding to Python
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index c9a8606..6f38cff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -11,7 +11,7 @@ python-pynzb (0.1.0-3) unstable; urgency=medium
* Change Homepage to GitHub.
* Build the Python 3 module and drop the Python 2 module (no rdeps).
* Run the test suite with pytest.
- * Call 2to3 during auto build.
+ * Call 2to3-3.Y during auto build for Python 3.X.
* 0001-set-message_id-properly-in-expat-parser.patch: fix an upstream code.
This change allows the tests to pass for Python 2.
* Move lxml to Suggests rather than Depends since there are fallbacks using
diff --git a/debian/rules b/debian/rules
index e7aefc0..1300e4a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@ export PYBUILD_TEST_ARGS=pynzb/tests.py
# utf-8 for the Python 3 build. If this turns out to be problematic, we can
# instead disable lxml support for the Python 3 build in pynzb/__init__.py and
# rely on the standard library fallbacks for XML parsing.
-export PYBUILD_AFTER_BUILD_python3=2to3 -n -w {build_dir}/pynzb/; sed -i -e 's/StringIO/BytesIO/g' -e 's/BytesIO(xml)/BytesIO(bytes(xml,"utf-8"))/' {build_dir}/pynzb/lxml_nzb.py
+export PYBUILD_AFTER_BUILD_python3=2to3-{version} -n -w {build_dir}/pynzb/; sed -i -e 's/StringIO/BytesIO/g' -e 's/BytesIO(xml)/BytesIO(bytes(xml,"utf-8"))/' {build_dir}/pynzb/lxml_nzb.py
%: