summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorAndrew Shadura <andrew@shadura.me>2015-08-27 18:45:31 +0200
committerAndrew Shadura <andrew@shadura.me>2015-08-27 18:45:31 +0200
commit8864659127afd728d2ae3f10664f65bcda6f7417 (patch)
treee691707efe75f01667fc54b27167f59e80cc0908 /debian/control
parent0679d83fa29d8c818d407dabbf934e9a43aa2987 (diff)
Add Python3 support, use pybuild.
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control48
1 files changed, 47 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index fd941ee..f391358 100644
--- a/debian/control
+++ b/debian/control
@@ -6,12 +6,17 @@ Build-Depends:
dh-python,
python-setuptools (>= 0.6.24),
python-all (>= 2.6.6-3),
+ python3-setuptools (>= 0.6.24),
+ python3-all,
python-sphinx (>= 1.0.7+dfsg) | python3-sphinx,
python-chardet,
+ python3-chardet,
python-nose,
+ python3-nose,
python-iniparse,
python-configparser,
python-six,
+ python3-six,
debhelper (>= 9)
Standards-Version: 3.9.4
Homepage: http://eugeny.github.io/reconfigure
@@ -20,7 +25,7 @@ Package: python-reconfigure
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}, python-configparser
Provides: ${python:Provides}
-Description: simple config file management library
+Description: simple config file management library (Python 2)
python-reconfigure provides easy and uniform access to various
kinds of configuration files, easily extendable with custom
parsers.
@@ -66,3 +71,44 @@ Description: simple config file management library (documentation)
parsers.
.
This package provides documentation to python-reconfigure.
+
+Package: python3-reconfigure
+Architecture: all
+Depends: ${misc:Depends}, ${python3:Depends}
+Description: simple config file management library (Python 3)
+ python-reconfigure provides easy and uniform access to various
+ kinds of configuration files, easily extendable with custom
+ parsers.
+ .
+ Supported configuration files:
+ * Ajenti (ajenti)
+ * BIND9 DNS (bind9)
+ * Crontabs (crontab)
+ * Samba CTDB (ctdb)
+ * ISC DHCPD / uDHCPD (dhcpd)
+ * NFS /etc/exports (exports)
+ * /etc/fstab (fstab)
+ * /etc/group (group)
+ * /etc/hosts (hosts)
+ * iptables-save dump (iptables)
+ * Netatalk afp.conf (netatalk)
+ * NSD DNS (nsd)
+ * /etc/passwd (passwd)
+ * /etc/resolv.conf (resolv)
+ * Samba (samba)
+ * Squid 3 (squid)
+ * Supervisord (supervisor)
+ .
+ Included parsers:
+ * BIND9 config (bind9)
+ * Crontab (crontab)
+ * NFS Exports (exports)
+ * .ini (ini)
+ * iptables-save (iptables)
+ * nginx-like (nginx)
+ * squid (squid)
+ * nsd (nsd)
+ * CSV-like space-separated values (ssv)
+ * JSON (jsonparser)
+ .
+ This is a Python 3 version of the package