summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2014-06-29 23:52:18 +0200
committerAndrew Shadura <andrew@shadura.me>2015-08-20 15:58:30 +0200
commite291e1eb02076fde5f2cfee4f1d01091a2319da3 (patch)
tree8fd2df78e635156aa667b15004c1db039bf747fa /debian/rules
parentd24bbfcea1fd03e19045e458b82ed0d76bf2f413 (diff)
parentfec1da7e6ea8a3b3b03befa4ff8dd31d539f163d (diff)
Imported Debian patch 0.1.50+git20140603-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 5 insertions, 8 deletions
diff --git a/debian/rules b/debian/rules
index 956298c..4d1de0f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,20 +1,17 @@
#!/usr/bin/make -f
%:
- dh $@ --with python2,sphinxdoc
+ dh $@ --with python2,sphinxdoc --buildsystem=pybuild
override_dh_auto_build:
dh_auto_build
$(MAKE) doc
-override_dh_auto_install:
- dh_auto_install -- COMPILE=--install-layout=deb
+override_dh_auto_clean:
+ rm -rf docs/build/*
+ dh_auto_clean
override_dh_installchangelogs:
dh_installchangelogs -X docs
-override_dh_auto_clean:
- rm -rf build build-stamp configure-stamp build/ MANIFEST
- dh_auto_clean || true
-
-.PHONY: override_dh_auto_build override_dh_auto_install override_dh_installchangelogs override_dh_auto_clean
+.PHONY: override_dh_auto_build override_dh_auto_clean override_dh_installchangelogs