summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorAndrew Shadura <andrewsh@debian.org>2013-09-19 14:07:20 +0200
committerAndrew Shadura <andrew@shadura.me>2015-08-20 15:58:26 +0200
commit9728f304866670b7460bca275aef563070efe666 (patch)
tree740fabd379f718164e0dd6e256664af98d074287 /debian/rules
parentff1408420159488a106492ccd11dd234967029b6 (diff)
Imported Debian patch 0.1.29-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 15 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index fb55c26..956298c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,11 +1,20 @@
#!/usr/bin/make -f
-# -*- makefile -*-
-DEB_PYTHON_SYSTEM := pysupport
+%:
+ dh $@ --with python2,sphinxdoc
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/python-distutils.mk
+override_dh_auto_build:
+ dh_auto_build
+ $(MAKE) doc
-clean::
+override_dh_auto_install:
+ dh_auto_install -- COMPILE=--install-layout=deb
+
+override_dh_installchangelogs:
+ dh_installchangelogs -X docs
+
+override_dh_auto_clean:
rm -rf build build-stamp configure-stamp build/ MANIFEST
- dh_clean
+ dh_auto_clean || true
+
+.PHONY: override_dh_auto_build override_dh_auto_install override_dh_installchangelogs override_dh_auto_clean