summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAndrej Shadura <andrew.shadura@collabora.co.uk>2019-06-26 12:59:30 -0500
committerAndrej Shadura <andrew.shadura@collabora.co.uk>2019-06-26 12:59:30 -0500
commit7c9b45a310d7773d1a83ad09889a5d6449846c89 (patch)
tree17f531d4fe8f3fdaef4d84fc1bbc1886ab88cb50 /debian
parent63e8daaad110c519663c92e188657d2fe25145b2 (diff)
Skip tests when not present in the upstream tarball
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/tests/control2
2 files changed, 2 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 861b893..deed631 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,5 @@ export LC_ALL=C.UTF-8
dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_auto_test:
+ [ -d tests/ ] && dh_auto_test -- --test-pytest --test-args='{dir}/tests'
: # ignore test results, idna test fail
- # TODO: current tarball doesn't include tests, uncomment when that changes
- # dh_auto_test -- --test-pytest --test-args='{dir}/tests'
diff --git a/debian/tests/control b/debian/tests/control
index c563563..c9945c7 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -1,4 +1,4 @@
-Test-Command: for p in $(pyversions -s) $(py3versions -s); do $p -m pytest tests/; done
+Test-Command: for p in $(pyversions -s) $(py3versions -s); do if [ -d tests/ ]; then $p -m pytest tests/; fi; done
Depends:
python-all,
python-pytest,