summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini60
1 files changed, 60 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..040fa64
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,60 @@
+[tox]
+envlist = coverage-clean,{py27,py34,py35,pypy}-{pyopenssl015,pyopenssl014}-{idna,noidna},flake8,manifest,readme,coverage-report
+
+[testenv]
+deps =
+ coverage
+ pytest
+ idna: idna
+ pyopenssl014: pyOpenSSL==0.14
+ pyopenssl015: pyOpenSSL==0.15.1
+passenv = LDFLAGS CFLAGS CPPFLAGS
+setenv =
+ PYTHONHASHSEED = 0
+ noidna: TRICKING_TOX = 1
+commands =
+ coverage run --parallel-mode -m pytest {posargs}
+ py35-pyopenssl015-idna: coverage run --parallel-mode -m pytest --doctest-modules --doctest-glob='*.rst' {posargs}
+
+
+[testenv:flake8]
+basepython = python3.5
+deps = flake8
+commands = flake8 setup.py src tests
+
+
+[testenv:docs]
+basepython = python3.5
+deps = sphinx
+commands =
+ sphinx-build -W -b html -d {envtmpdir}/doctrees docs docs/_build/html
+ sphinx-build -W -b doctest -d {envtmpdir}/doctrees docs docs/_build/html
+
+
+[testenv:manifest]
+basepython = python3.5
+deps = check-manifest
+commands = check-manifest
+
+
+[testenv:readme]
+basepython = python3.5
+deps = readme_renderer
+skip_install = true
+commands = python setup.py check -r -s
+
+
+[testenv:coverage-clean]
+basepython = python3.5
+deps = coverage
+skip_install = true
+commands = coverage erase
+
+
+[testenv:coverage-report]
+basepython = python3.5
+deps = coverage
+skip_install = true
+commands =
+ coverage combine
+ coverage report