summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini49
1 files changed, 24 insertions, 25 deletions
diff --git a/tox.ini b/tox.ini
index 040fa64..b3cae95 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,58 +1,57 @@
[tox]
-envlist = coverage-clean,{py27,py34,py35,pypy}-{pyopenssl015,pyopenssl014}-{idna,noidna},flake8,manifest,readme,coverage-report
+envlist = lint,py27,py37,pypy,pypy3,{py27,py36}-pyopensslLatest-noidna,{py27,py34,py35,py36}-{pyopenssl014,pyopensslLatest}-idna,{pypy,pypy3}-pyopensslLatest-idna,manifest,pypi-description,coverage-report
[testenv]
+extras = tests
deps =
- coverage
- pytest
idna: idna
- pyopenssl014: pyOpenSSL==0.14
- pyopenssl015: pyOpenSSL==0.15.1
+ pyopenssl014: pyOpenSSL>=0.14<0.15
+ pyopenssl015: pyOpenSSL>=0.15<0.16
+ pyopensslLatest: pyOpenSSL
passenv = LDFLAGS CFLAGS CPPFLAGS
setenv =
PYTHONHASHSEED = 0
noidna: TRICKING_TOX = 1
commands =
coverage run --parallel-mode -m pytest {posargs}
- py35-pyopenssl015-idna: coverage run --parallel-mode -m pytest --doctest-modules --doctest-glob='*.rst' {posargs}
+ py36-pyopensslLatest-idna: coverage run --parallel-mode -m pytest --doctest-modules --doctest-glob='*.rst' {posargs}
-[testenv:flake8]
-basepython = python3.5
-deps = flake8
-commands = flake8 setup.py src tests
+[testenv:lint]
+basepython = python3.7
+skip_install = true
+deps = pre-commit
+passenv = HOMEPATH # needed on Windows
+commands = pre-commit run --all-files --verbose
[testenv:docs]
-basepython = python3.5
-deps = sphinx
+basepython = python3.7
+extras = docs
commands =
sphinx-build -W -b html -d {envtmpdir}/doctrees docs docs/_build/html
sphinx-build -W -b doctest -d {envtmpdir}/doctrees docs docs/_build/html
[testenv:manifest]
-basepython = python3.5
+basepython = python3.7
deps = check-manifest
commands = check-manifest
-[testenv:readme]
-basepython = python3.5
-deps = readme_renderer
+[testenv:pypi-description]
+basepython = python3.7
skip_install = true
-commands = python setup.py check -r -s
-
-
-[testenv:coverage-clean]
-basepython = python3.5
-deps = coverage
-skip_install = true
-commands = coverage erase
+deps =
+ twine
+ pip >= 18.0.0
+commands =
+ pip wheel -w {envtmpdir}/build --no-deps .
+ twine check {envtmpdir}/build/*
[testenv:coverage-report]
-basepython = python3.5
+basepython = python3.7
deps = coverage
skip_install = true
commands =