summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2017-04-15 11:16:46 +0100
committerColin Watson <cjwatson@debian.org>2017-04-15 11:17:28 +0100
commit2ca0a47145b0f576b6590a4d11c3b2f41d971b79 (patch)
treef6ae13c7b2982e5d9e13efc3d471d86e648bd2ea
parent345fc7ca909a8c84dc1cc603a32cd3af9bad61ec (diff)
parent163d3b08aae6a133ed6558bb4281fda9e4cf1ddd (diff)
New upstream release (1.3.2)
-rw-r--r--.bumpversion.cfg2
-rw-r--r--.travis.yml26
-rw-r--r--CHANGELOG.rst7
-rw-r--r--PKG-INFO29
-rw-r--r--README.rst24
-rw-r--r--ci/templates/.travis.yml23
-rw-r--r--debian/.git-dpm14
-rw-r--r--debian/changelog6
-rw-r--r--docs/conf.py2
-rw-r--r--setup.py2
-rw-r--r--src/tblib.egg-info/PKG-INFO29
-rw-r--r--src/tblib/__init__.py9
-rw-r--r--tox.ini3
13 files changed, 158 insertions, 18 deletions
diff --git a/.bumpversion.cfg b/.bumpversion.cfg
index e4f2adf..c534b3c 100644
--- a/.bumpversion.cfg
+++ b/.bumpversion.cfg
@@ -1,5 +1,5 @@
[bumpversion]
-current_version = 1.3.1
+current_version = 1.3.2
commit = True
tag = True
diff --git a/.travis.yml b/.travis.yml
index fd82b90..c91785b 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -28,16 +28,40 @@ matrix:
- python: pypy
env:
- TOXENV=pypy,report,coveralls,codecov
+ - python: pypy3
+ env:
+ - TOXENV=pypy3,report,coveralls,codecov
before_install:
- python --version
- uname -a
- lsb_release -a
install:
- - pip install tox
+ - pip install -U tox virtualenv
- virtualenv --version
- easy_install --version
- pip --version
- tox --version
+ - |
+ set -ex
+ if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ (cd $HOME
+ wget https://bitbucket.org/squeaky/portable-pypy/downloads/pypy-5.7.1-linux_x86_64-portable.tar.bz2
+ tar xf pypy-5.7.1-linux_x86_64-portable.tar.bz2
+ pypy-5.7.1-linux_x86_64-portable/bin/pypy -m ensurepip
+ pypy-5.7.1-linux_x86_64-portable/bin/pypy -m pip install -U virtualenv)
+ export PATH=$HOME/pypy-5.7.1-linux_x86_64-portable/bin/:$PATH
+ export TOXPYTHON=$HOME/pypy-5.7.1-linux_x86_64-portable/bin/pypy
+ fi
+ if [[ $TRAVIS_PYTHON_VERSION == 'pypy3' ]]; then
+ (cd $HOME
+ wget https://bitbucket.org/squeaky/portable-pypy/downloads/pypy3.5-5.7.1-beta-linux_x86_64-portable.tar.bz2
+ tar xf pypy3.5-5.7.1-beta-linux_x86_64-portable.tar.bz2
+ pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3 -m ensurepip
+ pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3 -m pip install -U virtualenv)
+ export PATH=$HOME/pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/:$PATH
+ export TOXPYTHON=$HOME/pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3
+ fi
+ set +x
script:
- tox -v
after_failure:
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index f2992e7..031987c 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -2,6 +2,13 @@
Changelog
=========
+1.3.2 (2017-04-09)
+~~~~~~~~~~~~~~~~~~
+
+* Add support for PyPy3.5-5.7.1-beta. Previously ``AttributeError:
+ 'Frame' object has no attribute 'clear'`` could be raised. See PyPy
+ issue `#2532 <https://bitbucket.org/pypy/pypy/issues/2532/pypy3-attributeerror-frame-object-has-no>`_.
+
1.3.1 (2017-03-27)
~~~~~~~~~~~~~~~~~~
diff --git a/PKG-INFO b/PKG-INFO
index f73edc0..efef9cd 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: tblib
-Version: 1.3.1
+Version: 1.3.2
Summary: Traceback serialization library.
Home-page: https://github.com/ionelmc/python-tblib
Author: Ionel Cristian Mărieș
@@ -549,6 +549,26 @@ Description: ========
Exception: Guessing time !
<BLANKLINE>
+ Other weird stuff
+ `````````````````
+
+ Clearing traceback works (Python 3.4 and up)::
+
+ >>> tb = Traceback.from_string("""
+ ... File "skipped.py", line 123, in func_123
+ ... Traceback (most recent call last):
+ ... File "tests/examples.py", line 2, in func_a
+ ... func_b()
+ ... File "tests/examples.py", line 6, in func_b
+ ... func_c()
+ ... File "tests/examples.py", line 10, in func_c
+ ... func_d()
+ ... File "tests/examples.py", line 14, in func_d
+ ... Doesn't: matter
+ ... """)
+ >>> import traceback, sys
+ >>> if sys.version_info > (3, 4):
+ ... traceback.clear_frames(tb)
Credits
=======
@@ -559,6 +579,13 @@ Description: ========
Changelog
=========
+ 1.3.2 (2017-04-09)
+ ~~~~~~~~~~~~~~~~~~
+
+ * Add support for PyPy3.5-5.7.1-beta. Previously ``AttributeError:
+ 'Frame' object has no attribute 'clear'`` could be raised. See PyPy
+ issue `#2532 <https://bitbucket.org/pypy/pypy/issues/2532/pypy3-attributeerror-frame-object-has-no>`_.
+
1.3.1 (2017-03-27)
~~~~~~~~~~~~~~~~~~
diff --git a/README.rst b/README.rst
index b2d227c..a4838e7 100644
--- a/README.rst
+++ b/README.rst
@@ -57,9 +57,9 @@ Overview
:alt: PyPI Package latest release
:target: https://pypi.python.org/pypi/tblib
-.. |commits-since| image:: https://img.shields.io/github/commits-since/ionelmc/python-tblib/v1.3.1.svg
+.. |commits-since| image:: https://img.shields.io/github/commits-since/ionelmc/python-tblib/v1.3.2.svg
:alt: Commits since latest release
- :target: https://github.com/ionelmc/python-tblib/compare/v1.3.1...master
+ :target: https://github.com/ionelmc/python-tblib/compare/v1.3.2...master
.. |wheel| image:: https://img.shields.io/pypi/wheel/tblib.svg
:alt: PyPI Wheel
@@ -617,6 +617,26 @@ What if we have a local call stack ?
Exception: Guessing time !
<BLANKLINE>
+Other weird stuff
+`````````````````
+
+Clearing traceback works (Python 3.4 and up)::
+
+ >>> tb = Traceback.from_string("""
+ ... File "skipped.py", line 123, in func_123
+ ... Traceback (most recent call last):
+ ... File "tests/examples.py", line 2, in func_a
+ ... func_b()
+ ... File "tests/examples.py", line 6, in func_b
+ ... func_c()
+ ... File "tests/examples.py", line 10, in func_c
+ ... func_d()
+ ... File "tests/examples.py", line 14, in func_d
+ ... Doesn't: matter
+ ... """)
+ >>> import traceback, sys
+ >>> if sys.version_info > (3, 4):
+ ... traceback.clear_frames(tb)
Credits
=======
diff --git a/ci/templates/.travis.yml b/ci/templates/.travis.yml
index 6c04ae0..751558d 100644
--- a/ci/templates/.travis.yml
+++ b/ci/templates/.travis.yml
@@ -20,11 +20,32 @@ before_install:
- uname -a
- lsb_release -a
install:
- - pip install tox
+ - pip install -U tox virtualenv
- virtualenv --version
- easy_install --version
- pip --version
- tox --version
+ - |
+ set -ex
+ if [[ $TRAVIS_PYTHON_VERSION == 'pypy' ]]; then
+ (cd $HOME
+ wget https://bitbucket.org/squeaky/portable-pypy/downloads/pypy-5.7.1-linux_x86_64-portable.tar.bz2
+ tar xf pypy-5.7.1-linux_x86_64-portable.tar.bz2
+ pypy-5.7.1-linux_x86_64-portable/bin/pypy -m ensurepip
+ pypy-5.7.1-linux_x86_64-portable/bin/pypy -m pip install -U virtualenv)
+ export PATH=$HOME/pypy-5.7.1-linux_x86_64-portable/bin/:$PATH
+ export TOXPYTHON=$HOME/pypy-5.7.1-linux_x86_64-portable/bin/pypy
+ fi
+ if [[ $TRAVIS_PYTHON_VERSION == 'pypy3' ]]; then
+ (cd $HOME
+ wget https://bitbucket.org/squeaky/portable-pypy/downloads/pypy3.5-5.7.1-beta-linux_x86_64-portable.tar.bz2
+ tar xf pypy3.5-5.7.1-beta-linux_x86_64-portable.tar.bz2
+ pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3 -m ensurepip
+ pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3 -m pip install -U virtualenv)
+ export PATH=$HOME/pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/:$PATH
+ export TOXPYTHON=$HOME/pypy3.5-5.7.1-beta-linux_x86_64-portable/bin/pypy3
+ fi
+ set +x
script:
- tox -v
after_failure:
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 183bee6..646eeff 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,8 +1,8 @@
# see git-dpm(1) from git-dpm package
-d73804c7759eef8d3bb469686eba71c5cafa6824
-d73804c7759eef8d3bb469686eba71c5cafa6824
-d73804c7759eef8d3bb469686eba71c5cafa6824
-d73804c7759eef8d3bb469686eba71c5cafa6824
-python-tblib_1.3.1.orig.tar.gz
-f62dfdde3587172f1ab5e570929fe84a5e1b69b0
-25038
+163d3b08aae6a133ed6558bb4281fda9e4cf1ddd
+163d3b08aae6a133ed6558bb4281fda9e4cf1ddd
+163d3b08aae6a133ed6558bb4281fda9e4cf1ddd
+163d3b08aae6a133ed6558bb4281fda9e4cf1ddd
+python-tblib_1.3.2.orig.tar.gz
+b325a44710f8df79d5f96f2f2c67470c6ebc2561
+26958
diff --git a/debian/changelog b/debian/changelog
index d5fd707..9e1b66a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+python-tblib (1.3.2-1) UNRELEASED; urgency=medium
+
+ * New upstream release.
+
+ -- Colin Watson <cjwatson@debian.org> Sat, 15 Apr 2017 11:17:11 +0100
+
python-tblib (1.3.1-1) unstable; urgency=medium
* New upstream release.
diff --git a/docs/conf.py b/docs/conf.py
index be4aa37..551b880 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -26,7 +26,7 @@ project = 'tblib'
year = '2013-2017'
author = 'Ionel Cristian Mărieș'
copyright = '{0}, {1}'.format(year, author)
-version = release = '1.3.1'
+version = release = '1.3.2'
pygments_style = 'trac'
templates_path = ['.']
diff --git a/setup.py b/setup.py
index 03185b3..be19704 100644
--- a/setup.py
+++ b/setup.py
@@ -24,7 +24,7 @@ def read(*names, **kwargs):
setup(
name='tblib',
- version='1.3.1',
+ version='1.3.2',
license='BSD',
description='Traceback serialization library.',
long_description='%s\n%s' % (
diff --git a/src/tblib.egg-info/PKG-INFO b/src/tblib.egg-info/PKG-INFO
index f73edc0..efef9cd 100644
--- a/src/tblib.egg-info/PKG-INFO
+++ b/src/tblib.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.1
Name: tblib
-Version: 1.3.1
+Version: 1.3.2
Summary: Traceback serialization library.
Home-page: https://github.com/ionelmc/python-tblib
Author: Ionel Cristian Mărieș
@@ -549,6 +549,26 @@ Description: ========
Exception: Guessing time !
<BLANKLINE>
+ Other weird stuff
+ `````````````````
+
+ Clearing traceback works (Python 3.4 and up)::
+
+ >>> tb = Traceback.from_string("""
+ ... File "skipped.py", line 123, in func_123
+ ... Traceback (most recent call last):
+ ... File "tests/examples.py", line 2, in func_a
+ ... func_b()
+ ... File "tests/examples.py", line 6, in func_b
+ ... func_c()
+ ... File "tests/examples.py", line 10, in func_c
+ ... func_d()
+ ... File "tests/examples.py", line 14, in func_d
+ ... Doesn't: matter
+ ... """)
+ >>> import traceback, sys
+ >>> if sys.version_info > (3, 4):
+ ... traceback.clear_frames(tb)
Credits
=======
@@ -559,6 +579,13 @@ Description: ========
Changelog
=========
+ 1.3.2 (2017-04-09)
+ ~~~~~~~~~~~~~~~~~~
+
+ * Add support for PyPy3.5-5.7.1-beta. Previously ``AttributeError:
+ 'Frame' object has no attribute 'clear'`` could be raised. See PyPy
+ issue `#2532 <https://bitbucket.org/pypy/pypy/issues/2532/pypy3-attributeerror-frame-object-has-no>`_.
+
1.3.1 (2017-03-27)
~~~~~~~~~~~~~~~~~~
diff --git a/src/tblib/__init__.py b/src/tblib/__init__.py
index 6bb2fd2..0b03df3 100644
--- a/src/tblib/__init__.py
+++ b/src/tblib/__init__.py
@@ -15,7 +15,7 @@ except ImportError:
if not tb_set_next and not tproxy:
raise ImportError("Cannot use tblib. Runtime not supported.")
-__version__ = '1.3.1'
+__version__ = '1.3.2'
__all__ = 'Traceback',
PY3 = sys.version_info[0] == 3
@@ -51,6 +51,13 @@ class Frame(object):
])
self.f_code = Code(frame.f_code)
+ def clear(self):
+ # For compatibility with PyPy 3.5;
+ # clear() was added to frame in Python 3.4
+ # and is called by traceback.clear_frames(), which
+ # in turn is called by unittest.TestCase.assertRaises
+ pass
+
class Traceback(object):
diff --git a/tox.ini b/tox.ini
index bc3b1e2..7f0c1de 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,12 +11,13 @@ envlist =
[testenv]
basepython =
pypy: {env:TOXPYTHON:pypy}
+ pypy3: {env:TOXPYTHON:pypy3}
{py27,docs,spell}: {env:TOXPYTHON:python2.7}
py33: {env:TOXPYTHON:python3.3}
py34: {env:TOXPYTHON:python3.4}
py35: {env:TOXPYTHON:python3.5}
py36: {env:TOXPYTHON:python3.6}
- {bootstrap,clean,check,report,coveralls,codecov}: python3
+ {bootstrap,clean,check,report,coveralls,codecov}: {env:TOXPYTHON:python3}
setenv =
PYTHONPATH={toxinidir}/tests
PYTHONUNBUFFERED=yes