summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2018-10-28 15:11:45 +0000
committerColin Watson <cjwatson@debian.org>2018-10-28 15:11:45 +0000
commit620a7e4be214c21d335bfde8aed91784a5e96a2e (patch)
tree24e8a244ee0cfe15d9c0b7623ce43c5c9ce076bb /debian
parentbd0afd06eebffa287b5b945d1dc13c1349825bed (diff)
Fix test failures with Python 3.7
Closes: #912034
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/0001-Patch-tests-against-Python-3.7.patch35
-rw-r--r--debian/patches/series1
3 files changed, 41 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b5b96ad..d60d3cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,16 @@
python-tblib (1.3.2-3) UNRELEASED; urgency=medium
+ [ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
* d/watch: Use https protocol
* d/control: Remove ancient X-Python-Version field
* d/control: Remove ancient X-Python3-Version field
* Convert git repository from git-dpm to gbp layout
+ [ Colin Watson ]
+ * Apply patch from Fedora to fix test failures with Python 3.7 (closes:
+ #912034).
+
-- Ondřej Nový <onovy@debian.org> Thu, 15 Feb 2018 08:36:55 +0100
python-tblib (1.3.2-2) unstable; urgency=medium
diff --git a/debian/patches/0001-Patch-tests-against-Python-3.7.patch b/debian/patches/0001-Patch-tests-against-Python-3.7.patch
new file mode 100644
index 0000000..a151782
--- /dev/null
+++ b/debian/patches/0001-Patch-tests-against-Python-3.7.patch
@@ -0,0 +1,35 @@
+From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
+Date: Sat, 30 Jun 2018 20:51:57 -0400
+Subject: Patch tests against Python 3.7.
+
+Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
+
+Origin: vendor, https://src.fedoraproject.org/rpms/python-tblib/blob/master/f/0001-Patch-tests-against-Python-3.7.patch
+Bug: https://github.com/ionelmc/python-tblib/issues/36<Paste>
+Bug-Debian: https://bugs.debian.org/912034
+Last-Update: 2018-10-28
+---
+ README.rst | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/README.rst b/README.rst
+index a4838e7..051cc57 100644
+--- a/README.rst
++++ b/README.rst
+@@ -162,13 +162,13 @@ Unpickling
+ ::
+
+ >>> pickle.loads(s1)
+- (<...Exception'>, Exception('fail',), <traceback object at ...>)
++ (<...Exception'>, Exception('fail'...), <traceback object at ...>)
+
+ >>> pickle.loads(s2)
+- (<...Exception'>, Exception('fail',), <traceback object at ...>)
++ (<...Exception'>, Exception('fail'...), <traceback object at ...>)
+
+ >>> pickle.loads(s3)
+- (<...Exception'>, Exception('fail',), <traceback object at ...>)
++ (<...Exception'>, Exception('fail'...), <traceback object at ...>)
+
+ Raising
+ ~~~~~~~
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..ca9001c
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Patch-tests-against-Python-3.7.patch