summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2016-03-09 12:01:35 +0000
committerColin Watson <cjwatson@debian.org>2016-03-09 12:01:35 +0000
commitcfb910553e487aba8382a996edda5fcf8dcc96d6 (patch)
treee97952f1dc9b89c735d0fea9335f9c79295f7c71 /debian
parent1f759c26dd68247407310d7edcd3827f352623de (diff)
Switch to pybuild.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/python-tblib.install1
-rw-r--r--debian/python3-tblib.install1
-rwxr-xr-xdebian/rules47
4 files changed, 10 insertions, 40 deletions
diff --git a/debian/changelog b/debian/changelog
index a271a7f..d3535a6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ python-tblib (1.3.0-1) UNRELEASED; urgency=medium
* Stop using an awkward set of patches to tox.ini, and just run tests via
pytest instead.
* Use HTTPS for Vcs-* URLs.
+ * Switch to pybuild.
-- Colin Watson <cjwatson@debian.org> Wed, 27 Jan 2016 13:37:20 +0000
diff --git a/debian/python-tblib.install b/debian/python-tblib.install
deleted file mode 100644
index 2655300..0000000
--- a/debian/python-tblib.install
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/python2.*
diff --git a/debian/python3-tblib.install b/debian/python3-tblib.install
deleted file mode 100644
index b06a399..0000000
--- a/debian/python3-tblib.install
+++ /dev/null
@@ -1 +0,0 @@
-usr/lib/python3
diff --git a/debian/rules b/debian/rules
index fe32ac8..e90fd75 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,44 +1,15 @@
#! /usr/bin/make -f
-%:
- dh $@ --with python2,python3
-# Keep pristine copies of some files that setup.py likes to modify.
-BACKUP = \
- PKG-INFO \
- src/tblib.egg-info/PKG-INFO \
- src/tblib.egg-info/SOURCES.txt
+export PYBUILD_NAME := tblib
+export PYBUILD_TEST_PYTEST := 1
+export PYBUILD_TEST_ARGS := -vv tests {dir}/README.rst
-override_dh_auto_build:
- mkdir -p debian/backup
- set -e; for x in $(BACKUP); do \
- mkdir -p debian/backup/$$(dirname $$x); \
- cp -a $$x debian/backup/$$x; \
- done
- dh_auto_build
- set -e; for python in $$(py3versions -r); do \
- $$python setup.py build; \
- done
+%:
+ dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_auto_test:
- set -e; for python in $$(pyversions -r) $$(py3versions -r); do \
- PYTHONPATH=src $$python -m pytest -vv tests README.rst; \
- done
-
-override_dh_auto_clean:
- dh_auto_clean
- find -name \*.pyc -print0 | xargs -0r rm -f
- find -name __pycache__ -print0 | xargs -0r rm -rf
- rm -rf build
- if [ -e debian/backup ]; then \
- set -e; for x in $(BACKUP); do \
- cp -a debian/backup/$$x $$x; \
- done; \
- rm -rf debian/backup; \
- fi
+ PYTHONPATH=src dh_auto_test
-override_dh_auto_install:
- dh_auto_install
- set -e; for python in $$(py3versions -r); do \
- $$python setup.py install --root=$(CURDIR)/debian/tmp \
- --no-compile -O0 --install-layout=deb; \
- done
+override_dh_clean:
+ dh_clean
+ rm -rf .cache