summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorIonel Cristian Mărieș <contact@ionelmc.ro>2015-10-02 22:42:08 +0300
committerIonel Cristian Mărieș <contact@ionelmc.ro>2015-10-02 22:42:08 +0300
commit8d04e68fdac7ddf9f34f3d2f11f5f305815ef789 (patch)
tree8ada746468eb93994e805c0b893f43517f1592f0 /setup.cfg
parent7331663ecd68cee8f0310f87aaf257fb24a9e976 (diff)
Upgrade skel.
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg40
1 files changed, 40 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..a935c0f
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,40 @@
+[bdist_wheel]
+universal = 1
+
+[aliases]
+release = register clean --all sdist bdist_wheel
+
+[flake8]
+max-line-length = 140
+exclude = tests/*,*/migrations/*,*/south_migrations/*
+
+[pytest]
+norecursedirs =
+ .git
+ .tox
+ .env
+ dist
+ build
+ south_migrations
+ migrations
+python_files =
+ test_*.py
+ *_test.py
+ tests.py
+addopts =
+ -rxEfsw
+ --strict
+ --ignore=docs/conf.py
+ --ignore=setup.py
+ --ignore=ci
+ --ignore=.eggs
+ --doctest-modules
+ --doctest-glob=\*.rst
+ --tb=short
+
+[isort]
+force_single_line=True
+line_length=120
+known_first_party=tblib
+default_section=THIRDPARTY
+forced_separate=test_tblib