summaryrefslogtreecommitdiff
path: root/setup.cfg
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2015-12-18 11:03:30 +0000
committerColin Watson <cjwatson@debian.org>2015-12-18 11:03:30 +0000
commitf8de55537ac15958a980122b4c72f530be93d06a (patch)
tree525c76b2059fc9547a930065a0b9cc2abbfc0514 /setup.cfg
parentc6224cf33fda85bb50c0433138597730ab688f4a (diff)
parent3119b77d2cdff26a5d505cdea31415ebed7e8278 (diff)
Import python-tblib_1.2.0.orig.tar.gz
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg43
1 files changed, 42 insertions, 1 deletions
diff --git a/setup.cfg b/setup.cfg
index 6bc2ff3..4210281 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,5 +1,46 @@
+[bdist_wheel]
+universal = 1
+
+[aliases]
+release = register clean --all sdist bdist_wheel
+
+[flake8]
+max-line-length = 140
+exclude = tests/*,*/migrations/*,*/south_migrations/*
+
+[pytest]
+norecursedirs =
+ .git
+ .tox
+ .env
+ dist
+ build
+ south_migrations
+ migrations
+python_files =
+ test_*.py
+ *_test.py
+ tests.py
+addopts =
+ -rxEfsw
+ --strict
+ --ignore=docs/conf.py
+ --ignore=setup.py
+ --ignore=ci
+ --ignore=.eggs
+ --doctest-modules
+ --doctest-glob=\*.rst
+ --tb=short
+
+[isort]
+force_single_line = True
+line_length = 120
+known_first_party = tblib
+default_section = THIRDPARTY
+forced_separate = test_tblib
+
[egg_info]
-tag_date = 0
tag_build =
+tag_date = 0
tag_svn_revision = 0