summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSandro Tosi <morph@debian.org>2019-10-05 22:49:59 -0400
committerAndrej Shadura <andrewsh@debian.org>2019-10-07 08:50:13 +0200
commit90adbf8e2b3486833cadc9b1f852868325829495 (patch)
treefa7b98b396160fc5dcf593a9e5ed0ea0c5b43666
parent8ecb3c71e50126fb9f75471a6b7c0451c8bf88ae (diff)
Drop python2 support
Closes: #938240
-rw-r--r--debian/changelog6
-rw-r--r--debian/control17
-rw-r--r--debian/python-unpaddedbase64.docs1
-rwxr-xr-xdebian/rules2
4 files changed, 7 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 403b322..12e0fcb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+python-unpaddedbase64 (1.1.0-5) UNRELEASED; urgency=medium
+
+ * Drop python2 support (Closes: #938240).
+
+ -- Sandro Tosi <morph@debian.org> Sat, 05 Oct 2019 22:48:01 -0400
+
python-unpaddedbase64 (1.1.0-4) unstable; urgency=medium
* Enable autopkgtest CI.
diff --git a/debian/control b/debian/control
index 9c13de1..a931234 100644
--- a/debian/control
+++ b/debian/control
@@ -5,8 +5,6 @@ Priority: optional
Build-Depends:
debhelper-compat (= 12),
dh-python,
- python-all (>= 2.6.6-3),
- python-setuptools (>= 0.6.24),
python3-all,
python3-setuptools (>= 0.6.24)
Standards-Version: 4.3.0
@@ -15,21 +13,6 @@ Testsuite: autopkgtest-pkg-python
Vcs-Browser: https://salsa.debian.org/matrix-team/python-unpaddedbase64
Vcs-Git: https://salsa.debian.org/matrix-team/python-unpaddedbase64.git
-Package: python-unpaddedbase64
-Architecture: all
-Depends:
- ${misc:Depends},
- ${python:Depends}
-Provides: ${python:Provides}
-Description: unpadded Base64 implementation in Python
- A module to encode and decode Base64 without "=" padding.
- .
- RFC 4648 specifies that Base64 should be padded to a multiple of 4 bytes
- using "=" characters. However this conveys no benefit so many protocols choose
- to use Base64 without the "=" padding.
- .
- This package is for Python 2.
-
Package: python3-unpaddedbase64
Architecture: all
Depends:
diff --git a/debian/python-unpaddedbase64.docs b/debian/python-unpaddedbase64.docs
deleted file mode 100644
index a1320b1..0000000
--- a/debian/python-unpaddedbase64.docs
+++ /dev/null
@@ -1 +0,0 @@
-README.rst
diff --git a/debian/rules b/debian/rules
index e544c9d..b10cfc7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,4 +3,4 @@
export PYBUILD_NAME=unpaddedbase64
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild