summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2016-05-15 17:20:43 +0200
committerGuido Günther <agx@sigxcpu.org>2016-05-15 17:55:49 +0200
commit00662018fc223b14f4d2a26af52298eddbac55ec (patch)
tree6cf6538e1e9d498af59f2e83014c8400d15bb772
parentdacd5347ed80eaf24adc1790d369ee334810af40 (diff)
Python3 support
Closes: #747554
-rw-r--r--debian/control14
-rw-r--r--debian/python-vobject.install1
-rw-r--r--debian/python3-vobject.install1
-rwxr-xr-xdebian/rules1
4 files changed, 16 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index c3f2529..c98e84d 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,11 @@ Section: python
Priority: optional
Maintainer: Calendarserver Maintainers <calendarserver-maintainers@lists.alioth.debian.org>
Uploaders: Guido Günther <agx@sigxcpu.org>, Jelmer Vernooij <jelmer@debian.org>
-Build-Depends: cdbs, debhelper (>= 5), python-dev, dh-python, python-dateutil, python-setuptools
+Build-Depends: cdbs, debhelper (>= 5), python-dev, dh-python,
+ python-dateutil,
+ python-setuptools,
+ python3-dateutil,
+ python3-setuptools,
Standards-Version: 3.9.7
Vcs-Git: git://git.debian.org/git/calendarserver/python-vobject.git
Vcs-Browser: http://git.debian.org/?p=calendarserver/python-vobject.git
@@ -17,3 +21,11 @@ Description: parse iCalendar and VCards in Python
Parses iCalendar and vCard files into Python data structures, decoding the
relevant encodings. Also serializes vobject data structures to valid iCalendar
or vCard unicode strings.
+
+Package: python3-vobject
+Architecture: all
+Depends: ${python3:Depends}, ${misc:Depends}, python3-dateutil (>= 1.1)
+Description: parse iCalendar and VCards in Python3
+ Parses iCalendar and vCard files into Python3 data structures, decoding the
+ relevant encodings. Also serializes vobject data structures to valid iCalendar
+ or vCard unicode strings.
diff --git a/debian/python-vobject.install b/debian/python-vobject.install
new file mode 100644
index 0000000..4870883
--- /dev/null
+++ b/debian/python-vobject.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/python2.?/
diff --git a/debian/python3-vobject.install b/debian/python3-vobject.install
new file mode 100644
index 0000000..b6a91df
--- /dev/null
+++ b/debian/python3-vobject.install
@@ -0,0 +1 @@
+debian/tmp/usr/lib/python3/
diff --git a/debian/rules b/debian/rules
index 3f484f8..7feae8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,5 +10,6 @@ DEB_PYTHON_INSTALL_ARGS_ALL += --single-version-externally-managed
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
build/python-vobject::
python tests.py
+ python3 tests.py
endif