summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@debian.org>2016-09-04 16:55:40 +0000
committerJelmer Vernooij <jelmer@debian.org>2016-09-04 16:55:40 +0000
commit2399f48881cc3ba68648e2191069e15a7088dbc5 (patch)
tree97ad21b670f8dc149ca5aa3f2f26dc2baa7300b3
parent7f3a924dfa30f86a1b95b809cf78685a8e69eaa9 (diff)
Drop patch Fix-ORG-fields-with-multiple-components: applied upstream.
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch53
3 files changed, 2 insertions, 54 deletions
diff --git a/debian/changelog b/debian/changelog
index 59402ff..d707bd3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,8 @@
python-vobject (0.9.3-2) UNRELEASED; urgency=medium
* Merge 0.9.2-{2,3} changes.
+ * Drop patch Fix-ORG-fields-with-multiple-components: applied
+ upstream.
-- Jelmer Vernooij <jelmer@debian.org> Sun, 04 Sep 2016 16:53:01 +0000
diff --git a/debian/patches/series b/debian/patches/series
index 870c77a..23c513c 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,2 @@
Don-t-install-ics_diff.patch
Treat-untils-as-floating.patch
-vcard-Fix-ORG-fields-with-multiple-components.patch
diff --git a/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch b/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch
deleted file mode 100644
index befb779..0000000
--- a/debian/patches/vcard-Fix-ORG-fields-with-multiple-components.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From: Markus Unterwaditzer <markus@unterwaditzer.net>
-Date: Wed, 13 Apr 2016 22:43:39 +0200
-Subject: vcard: Fix ORG fields with multiple components
-
----
- test_files/simple_3_0_test.ics | 2 +-
- tests.py | 7 ++++++-
- vobject/vcard.py | 1 +
- 3 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/test_files/simple_3_0_test.ics b/test_files/simple_3_0_test.ics
-index d5e4642..1faf80d 100644
---- a/test_files/simple_3_0_test.ics
-+++ b/test_files/simple_3_0_test.ics
-@@ -9,5 +9,5 @@ TEL;type=CELL:+01-(0)5-555.55.55
- ACCOUNT;type=HOME:010-1234567-05
- ADR;type=HOME:;;Haight Street 512\;\nEscape\, Test;Novosibirsk;;80214;Gnuland
- TEL;type=HOME:+01-(0)2-876.54.32
--ORG:University of Novosibirsk, Department of Octopus Parthenogenesis
-+ORG:University of Novosibirsk;Department of Octopus Parthenogenesis
- END:VCARD
-diff --git a/tests.py b/tests.py
-index 2073930..6b0fad9 100644
---- a/tests.py
-+++ b/tests.py
-@@ -516,9 +516,14 @@ class TestVcards(unittest.TestCase):
- #)
- self.assertEqual(
- card.org.value,
-- "University of Novosibirsk, Department of Octopus Parthenogenesis"
-+ ["University of Novosibirsk", "Department of Octopus Parthenogenesis"]
- )
-
-+ for _ in range(3):
-+ new_card = base.readOne(card.serialize())
-+ self.assertEqual(new_card.org.value, card.org.value)
-+ card = new_card
-+
-
- class TestIcalendar(unittest.TestCase):
- """
-diff --git a/vobject/vcard.py b/vobject/vcard.py
-index dd60b73..0aec844 100644
---- a/vobject/vcard.py
-+++ b/vobject/vcard.py
-@@ -338,6 +338,7 @@ class OrgBehavior(VCardBehavior):
- if obj.isNative:
- return obj
- obj.isNative = True
-+ obj.value = splitFields(obj.value)
- return obj
-
- @staticmethod