summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PKG-INFO2
-rwxr-xr-xez_setup/README.txt15
-rwxr-xr-x[-rw-r--r--]ez_setup/__init__.py (renamed from ez_setup.py)35
-rwxr-xr-xsetup.py3
-rw-r--r--src/vobject.egg-info/PKG-INFO2
-rw-r--r--src/vobject.egg-info/SOURCES.txt3
6 files changed, 46 insertions, 14 deletions
diff --git a/PKG-INFO b/PKG-INFO
index 0c5814a..a2891e2 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.0
Name: vobject
-Version: 0.4.9
+Version: 0.5.0
Summary: VObject: module for reading vCard and vCalendar files
Home-page: http://vobject.skyhouseconsulting.com
Author: Jeffrey Harris
diff --git a/ez_setup/README.txt b/ez_setup/README.txt
new file mode 100755
index 0000000..9287f5a
--- /dev/null
+++ b/ez_setup/README.txt
@@ -0,0 +1,15 @@
+This directory exists so that Subversion-based projects can share a single
+copy of the ``ez_setup`` bootstrap module for ``setuptools``, and have it
+automatically updated in their projects when ``setuptools`` is updated.
+
+For your convenience, you may use the following svn:externals definition::
+
+ ez_setup svn://svn.eby-sarna.com/svnroot/ez_setup
+
+You can set this by executing this command in your project directory::
+
+ svn propedit svn:externals .
+
+And then adding the line shown above to the file that comes up for editing.
+Then, whenever you update your project, ``ez_setup`` will be updated as well.
+
diff --git a/ez_setup.py b/ez_setup/__init__.py
index 3367510..9e9b281 100644..100755
--- a/ez_setup.py
+++ b/ez_setup/__init__.py
@@ -14,8 +14,8 @@ the appropriate options to ``use_setuptools()``.
This file can also be run as a script to install or upgrade setuptools.
"""
import sys
-DEFAULT_VERSION = "0.6c1"
-DEFAULT_URL = "http://cheeseshop.python.org/packages/%s/s/setuptools/" % sys.version[:3]
+DEFAULT_VERSION = "0.6c7"
+DEFAULT_URL = "http://pypi.python.org/packages/%s/s/setuptools/" % sys.version[:3]
md5_data = {
'setuptools-0.6b1-py2.3.egg': '8822caf901250d848b996b7f25c6e6ca',
@@ -28,6 +28,23 @@ md5_data = {
'setuptools-0.6b4-py2.4.egg': '4cb2a185d228dacffb2d17f103b3b1c4',
'setuptools-0.6c1-py2.3.egg': 'b3f2b5539d65cb7f74ad79127f1a908c',
'setuptools-0.6c1-py2.4.egg': 'b45adeda0667d2d2ffe14009364f2a4b',
+ 'setuptools-0.6c2-py2.3.egg': 'f0064bf6aa2b7d0f3ba0b43f20817c27',
+ 'setuptools-0.6c2-py2.4.egg': '616192eec35f47e8ea16cd6a122b7277',
+ 'setuptools-0.6c3-py2.3.egg': 'f181fa125dfe85a259c9cd6f1d7b78fa',
+ 'setuptools-0.6c3-py2.4.egg': 'e0ed74682c998bfb73bf803a50e7b71e',
+ 'setuptools-0.6c3-py2.5.egg': 'abef16fdd61955514841c7c6bd98965e',
+ 'setuptools-0.6c4-py2.3.egg': 'b0b9131acab32022bfac7f44c5d7971f',
+ 'setuptools-0.6c4-py2.4.egg': '2a1f9656d4fbf3c97bf946c0a124e6e2',
+ 'setuptools-0.6c4-py2.5.egg': '8f5a052e32cdb9c72bcf4b5526f28afc',
+ 'setuptools-0.6c5-py2.3.egg': 'ee9fd80965da04f2f3e6b3576e9d8167',
+ 'setuptools-0.6c5-py2.4.egg': 'afe2adf1c01701ee841761f5bcd8aa64',
+ 'setuptools-0.6c5-py2.5.egg': 'a8d3f61494ccaa8714dfed37bccd3d5d',
+ 'setuptools-0.6c6-py2.3.egg': '35686b78116a668847237b69d549ec20',
+ 'setuptools-0.6c6-py2.4.egg': '3c56af57be3225019260a644430065ab',
+ 'setuptools-0.6c6-py2.5.egg': 'b2f8a7520709a5b34f80946de5f02f53',
+ 'setuptools-0.6c7-py2.3.egg': '209fdf9adc3a615e5115b725658e13e2',
+ 'setuptools-0.6c7-py2.4.egg': '5a8f954807d46a0fb67cf1f26c55a82e',
+ 'setuptools-0.6c7-py2.5.egg': '45d2ad28f9750e7434111fde831e8372',
}
import sys, os
@@ -77,13 +94,13 @@ def use_setuptools(
try:
pkg_resources.require("setuptools>="+version)
- except pkg_resources.VersionConflict:
+ except pkg_resources.VersionConflict, e:
# XXX could we install in a subprocess here?
print >>sys.stderr, (
"The required version of setuptools (>=%s) is not available, and\n"
"can't be installed while this script is running. Please install\n"
- " a more recent version first."
- ) % version
+ " a more recent version first.\n\n(Currently using %r)"
+ ) % (version, e.args[0])
sys.exit(2)
def download_setuptools(
@@ -139,15 +156,15 @@ def main(argv, version=DEFAULT_VERSION):
try:
import setuptools
except ImportError:
- import tempfile, shutil
- tmpdir = tempfile.mkdtemp(prefix="easy_install-")
+ egg = None
try:
- egg = download_setuptools(version, to_dir=tmpdir, delay=0)
+ egg = download_setuptools(version, delay=0)
sys.path.insert(0,egg)
from setuptools.command.easy_install import main
return main(list(argv)+[egg]) # we're done here
finally:
- shutil.rmtree(tmpdir)
+ if egg and os.path.exists(egg):
+ os.unlink(egg)
else:
if setuptools.__version__ == '0.0.1':
# tell the user to uninstall obsolete version
diff --git a/setup.py b/setup.py
index a551e4e..fb1ca74 100755
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-#!/usr/bin/env python
"""VObject: module for reading vCard and vCalendar files
Parses iCalendar and vCard files into Python data structures, decoding the relevant encodings. Also serializes vobject data structures to iCalendar, vCard, or (expirementally) hCalendar unicode strings.
@@ -24,7 +23,7 @@ from setuptools import setup, find_packages
# Metadata
PACKAGE_NAME = "vobject"
-PACKAGE_VERSION = "0.4.9"
+PACKAGE_VERSION = "0.5.0"
ALL_EXTS = ['*.py', '*.ics', '*.txt']
diff --git a/src/vobject.egg-info/PKG-INFO b/src/vobject.egg-info/PKG-INFO
index 0c5814a..a2891e2 100644
--- a/src/vobject.egg-info/PKG-INFO
+++ b/src/vobject.egg-info/PKG-INFO
@@ -1,6 +1,6 @@
Metadata-Version: 1.0
Name: vobject
-Version: 0.4.9
+Version: 0.5.0
Summary: VObject: module for reading vCard and vCalendar files
Home-page: http://vobject.skyhouseconsulting.com
Author: Jeffrey Harris
diff --git a/src/vobject.egg-info/SOURCES.txt b/src/vobject.egg-info/SOURCES.txt
index 137398e..c0d957a 100644
--- a/src/vobject.egg-info/SOURCES.txt
+++ b/src/vobject.egg-info/SOURCES.txt
@@ -1,8 +1,9 @@
ACKNOWLEDGEMENTS.txt
LICENSE.txt
README.txt
-ez_setup.py
setup.py
+ez_setup/README.txt
+ez_setup/__init__.py
src/vobject/__init__.py
src/vobject/base.py
src/vobject/behavior.py