summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py44
1 files changed, 25 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 2516b3e..bf3c141 100755
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,30 @@
"""VObject: module for reading vCard and vCalendar files
+Description
+-----------
+
Parses iCalendar and vCard files into Python data structures, decoding the relevant encodings. Also serializes vobject data structures to iCalendar, vCard, or (expirementally) hCalendar unicode strings.
+Requirements
+------------
+
Requires python 2.4 or later, dateutil (http://labix.org/python-dateutil) 1.1 or later.
-Recent changes:
-- Added VAVAILABILITY support
-- Improved wrapping of unicode lines, serialize encodes unicode as utf-8 by default
+Recent changes
+--------------
-For older changes, see http://vobject.skyhouseconsulting.com/history.html or http://websvn.osafoundation.org/listing.php?repname=vobject&path=/trunk/
+ * Allow unicode names for TZIDs
+ * Worked around Lotus Notes use of underscores in names by just silently replacing
+ with dashes
+ * When allowing quoted-printable data, honor CHARSET for each line, defaulting to
+ iso-8859-1
+ * Simplified directory layout, unit tests are now available via setup.py test
+ * Added VAVAILABILITY support
+ * Improved wrapping of unicode lines, serialize encodes unicode as utf-8 by default
+
+For older changes, see
+ * http://vobject.skyhouseconsulting.com/history.html or
+ * http://websvn.osafoundation.org/listing.php?repname=vobject&path=/trunk/
"""
@@ -17,33 +33,23 @@ use_setuptools()
from setuptools import setup, find_packages
-#from distutils.core import setup
-
-# Metadata
-PACKAGE_NAME = "vobject"
-PACKAGE_VERSION = "0.6.0"
-
-ALL_EXTS = ['*.py', '*.ics', '*.txt']
-
-packages = ['vobject']
-
doclines = __doc__.splitlines()
setup(name = "vobject",
- version = PACKAGE_VERSION,
+ version = "0.6.6",
author = "Jeffrey Harris",
author_email = "jeffrey@osafoundation.org",
license = "Apache",
zip_safe = True,
url = "http://vobject.skyhouseconsulting.com",
entry_points = { 'console_scripts': ['ics_diff = vobject.ics_diff:main'] },
- package_dir = {'':'src'},
- package_data = {'': ALL_EXTS},
+ include_package_data = True,
+ test_suite = "test_vobject",
install_requires = ['python-dateutil >= 1.1'],
-
+
platforms = ["any"],
- packages = ["vobject"],
+ packages = find_packages(),
description = doclines[0],
long_description = "\n".join(doclines[2:]),
classifiers = """