summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndřej Nový <onovy@debian.org>2019-08-09 08:22:30 +0200
committerOndřej Nový <onovy@debian.org>2019-08-09 08:23:16 +0200
commitdb0184286d69a53acd2a13a1b6f37b7f1af60f6e (patch)
tree58eed54873e46a6d7c1af9cc55bb46c215b0744e
parent69c13b0ce4b82856c2f548789b31069ec437ac6f (diff)
Drop Python 2 support.
-rw-r--r--debian/changelog1
-rw-r--r--debian/control23
-rw-r--r--debian/python-wheezy.template.postinst10
-rw-r--r--debian/python-wheezy.template.prerm9
-rwxr-xr-xdebian/rules4
5 files changed, 3 insertions, 44 deletions
diff --git a/debian/changelog b/debian/changelog
index f495b1b..d6db503 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ python-wheezy.template (0.1.167-2) UNRELEASED; urgency=medium
* d/copyright: Use https protocol in Format field.
* Use debhelper-compat instead of debian/compat.
* d/control: Set Vcs-* to salsa.debian.org.
+ * Drop Python 2 support.
-- Ondřej Nový <onovy@debian.org> Fri, 09 Aug 2019 08:22:11 +0200
diff --git a/debian/control b/debian/control
index e0f9b80..05e0a1e 100644
--- a/debian/control
+++ b/debian/control
@@ -3,13 +3,9 @@ Section: utils
Priority: optional
Maintainer: Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Uploaders: Andrew Shadura <andrewsh@debian.org>
-Build-Depends: cython,
- cython3,
+Build-Depends: cython3,
debhelper-compat (= 10),
dh-python,
- python-all-dev,
- python-requests,
- python-setuptools,
python3-all-dev,
python3-requests,
python3-setuptools
@@ -18,23 +14,6 @@ Homepage: https://bitbucket.org/akorn/wheezy.template
Vcs-Git: https://salsa.debian.org/python-team/modules/python-wheezy.template.git
Vcs-Browser: https://salsa.debian.org/python-team/modules/python-wheezy.template
-Package: python-wheezy.template
-Architecture: any
-Depends: ${misc:Depends},
- ${python:Depends},
- ${shlibs:Depends}
-Provides: ${python:Provides}
-Description: a lightweight template library (Python 2 package)
- wheezy.template is a lightweight template library in pure Python code.
- .
- * Compact, expressive, clean: minimises the number of keystrokes
- required to build a template.
- * Intuitive, little time to learn: requires only basic Python
- programming skills plus HTML markup knowledge.
- * Do not repeat yourself: master layout templates for inheritance;
- include and import directives for maximum reuse.
- * Fast: maximum rendering performance.
-
Package: python3-wheezy.template
Architecture: any
Depends: ${misc:Depends},
diff --git a/debian/python-wheezy.template.postinst b/debian/python-wheezy.template.postinst
deleted file mode 100644
index b6f6737..0000000
--- a/debian/python-wheezy.template.postinst
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh
-
-set -e
-
-if [ "$1" = "configure" ]
-then
- update-alternatives --install /usr/bin/wheezy.template wheezy.template /usr/bin/wheezy.template-python2 200
-fi
-
-#DEBHELPER#
diff --git a/debian/python-wheezy.template.prerm b/debian/python-wheezy.template.prerm
deleted file mode 100644
index 4d92e1f..0000000
--- a/debian/python-wheezy.template.prerm
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-set -e
-
-if [ "$1" = "remove" ]
-then
- update-alternatives --remove wheezy.template /usr/bin/wheezy.template-python2
-fi
-
-#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index 3133337..8eb8464 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,13 +3,11 @@
export PYBUILD_NAME=wheezy.template
%:
- dh $@ --with python2,python3 --buildsystem=pybuild
+ dh $@ --with python3 --buildsystem=pybuild
override_dh_auto_install:
dh_auto_install
- mv debian/python-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME) debian/python-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python2
mv debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME) debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python3
- sed -i '1s,.*,#!/usr/bin/python2,' debian/python-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python2
sed -i '1s,.*,#!/usr/bin/python3,' debian/python3-$(PYBUILD_NAME)/usr/bin/$(PYBUILD_NAME)-python3
.PHONY: override_dh_auto_install