summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArto Jantunen <viiru@debian.org>2019-07-09 20:11:37 +0300
committerArto Jantunen <viiru@debian.org>2019-07-09 20:14:28 +0300
commita2f0a9c7a086b66509c444e105a7bc48ee0942d1 (patch)
tree5bb6eb1404f1089fdc829ea3e8b215c323f1ae8c
parent9d31583a0ca28b6c6e5702265d4f2e92bab66c53 (diff)
Convert to use pybuild
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules8
3 files changed, 14 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 5348646..980ae8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,10 +1,15 @@
pytrainer (2.0.0~rc1-2) UNRELEASED; urgency=medium
+ [ Ondřej Nový ]
* d/control: Remove ancient X-Python-Version field.
* d/copyright: Use https protocol in Format field.
* d/changelog: Remove trailing whitespaces.
- -- Ondřej Nový <onovy@debian.org> Wed, 09 Jan 2019 13:58:23 +0100
+ [ Arto Jantunen ]
+ * Remove Christian Perrier from Uploaders (Closes: #927550)
+ * Convert to use pybuild
+
+ -- Arto Jantunen <viiru@debian.org> Tue, 09 Jul 2019 20:14:11 +0300
pytrainer (2.0.0~rc1-1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index e494193..03e3884 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Vcs-Git: https://salsa.debian.org/python-team/applications/pytrainer.git
Package: pytrainer
Architecture: all
-Depends: ${misc:Depends}, ${python:Depends}, python, python-dateutil, python-lxml, python-matplotlib, python-migrate (>= 0.5.4), python-gi, gir1.2-gtk-3.0, python-cairo
+Depends: ${misc:Depends}, ${python:Depends}, python-gi, gir1.2-gtk-3.0, python-cairo
Recommends: zenity, gpsbabel
Description: desktop application for logging sport activities
Pytrainer is a desktop application for logging and graphing sporting
diff --git a/debian/rules b/debian/rules
index 18bcae9..9a83958 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,3 +1,9 @@
#!/usr/bin/make -f
+export PYBUILD_NAME=pytrainer
+export PYBUILD_VERSIONS=2.7
+
%:
- dh $@ --with python2
+ dh $@ --with python2 --buildsystem=pybuild
+
+override_dh_auto_test:
+ TZ=Europe/Kaliningrad LC_ALL=en_US.UTF-8 dh_auto_test