summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog7
-rw-r--r--debian/tests/control2
-rwxr-xr-xdebian/tests/py-load8
3 files changed, 17 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index d86020f..6a8c55c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+pyvisa-py (0.3.1-2) unstable; urgency=medium
+
+ * debian/tests:
+ - Added autopkgtest
+
+ -- Ruben Undheim <ruben.undheim@gmail.com> Sun, 02 Dec 2018 10:53:41 +0100
+
pyvisa-py (0.3.1-1) unstable; urgency=medium
[ Ruben Undheim ]
diff --git a/debian/tests/control b/debian/tests/control
new file mode 100644
index 0000000..f235473
--- /dev/null
+++ b/debian/tests/control
@@ -0,0 +1,2 @@
+Tests: py-load
+Depends: python3-pyvisa-py
diff --git a/debian/tests/py-load b/debian/tests/py-load
new file mode 100755
index 0000000..1a79d5a
--- /dev/null
+++ b/debian/tests/py-load
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+cd /tmp
+python3 -c "__import__('pyvisa-py')"
+
+echo "done"