summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Undheim <ruben.undheim@gmail.com>2018-08-19 22:16:18 +0200
committerRuben Undheim <ruben.undheim@gmail.com>2018-08-19 22:16:18 +0200
commit138ccf64e6f2e013d5fb87d91b121a8892b6812d (patch)
tree13ede17c667bca8f466783ce0e5f4d224cded9c7
parente40fb378190a3cb174fb61977ce1e2907cf09c95 (diff)
Refreshed patches
-rw-r--r--debian/patches/0001-fix-build.patch11
1 files changed, 5 insertions, 6 deletions
diff --git a/debian/patches/0001-fix-build.patch b/debian/patches/0001-fix-build.patch
index 562edcc..84912b1 100644
--- a/debian/patches/0001-fix-build.patch
+++ b/debian/patches/0001-fix-build.patch
@@ -7,16 +7,15 @@ Subject: Fix build
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/setup.py b/setup.py
-index a3d05a8..43c0732 100644
+index 2086c01..75652d0 100644
--- a/setup.py
+++ b/setup.py
-@@ -16,13 +16,14 @@ except ImportError:
-
+@@ -12,12 +12,13 @@ except ImportError:
def read(filename):
-- with open(filename, 'r') as f:
-+ with open(filename, 'rb') as f:
- return f.read()
+ with open(filename, 'rb') as f:
+- return f.read().decode('utf8')
++ return f.read()
+a2 = read('AUTHORS').decode('utf-8')
+a3 = read('CHANGES').decode('utf-8')