summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Campbell <ijc@debian.org>2019-01-02 15:39:19 +0000
committerIan Campbell <ijc@debian.org>2019-01-02 17:08:12 +0000
commit9d74918ba1ff122606cc6a8545c46cfa139aaa87 (patch)
treeb243c0f6e6b186359f0588eff353faaa388b0163
parentf8b3b9f0e8f42b23b1de4371ef613c20d2cfcbc0 (diff)
Run `udevadm trigger` from postinst
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/qcontrol.postinst3
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 819cea7..1eccd1f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
qcontrol (0.5.6-3) UNRELEASED; urgency=medium
* Use `dh_installudev` rather than open coding.
+ * Run `udevadm trigger` from postinst so that the gpio keys device is tagged
+ before trying to start the qcontrol services (which depend on the tagged
+ device). (Closes: #914160, again!).
-- Ian Campbell <ijc@debian.org> Wed, 02 Jan 2019 15:27:25 +0000
diff --git a/debian/qcontrol.postinst b/debian/qcontrol.postinst
index f12c42a..702545a 100755
--- a/debian/qcontrol.postinst
+++ b/debian/qcontrol.postinst
@@ -33,6 +33,9 @@ fi
case "$1" in
configure)
+ # Ensures that a newly installed qcontrol.rules actually tags the
+ # device such that systemd sees it.
+ udevadm trigger --subsystem-match input --property-match ID_PATH=platform-gpio_keys
if [ -x /usr/sbin/update-initramfs ]; then
update-initramfs -u
fi