summaryrefslogtreecommitdiff
path: root/debian/patches/02_use_tkcon_from_debian.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02_use_tkcon_from_debian.patch')
-rw-r--r--debian/patches/02_use_tkcon_from_debian.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/02_use_tkcon_from_debian.patch b/debian/patches/02_use_tkcon_from_debian.patch
new file mode 100644
index 0000000..278a7de
--- /dev/null
+++ b/debian/patches/02_use_tkcon_from_debian.patch
@@ -0,0 +1,37 @@
+From: Ruben Undheim <ruben.undheim@gmail.com>
+Date: Fri, 20 Feb 2015 00:00:00 +0100
+Subject: Use tkon from debian
+
+This patch makes sure that the tkcon version from debian is used instead of the version bundled with the source of qrouter.
+
+===================================================================
+---
+ Makefile.in | 1 -
+ qrouter.sh.in | 2 +-
+ 2 files changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 7586e15..a7b68ba 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -111,7 +111,6 @@ install-tcl: qrouter.sh qrouter.tcl qrouter$(SHDLIB_EXT) \
+ $(INSTALL) qrouterexec$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) qrouternullg$(EXEEXT) $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) -m 0644 console.tcl $(DESTDIR)${LIBINSTALL}
+- $(INSTALL) tkcon.tcl $(DESTDIR)${LIBINSTALL}
+ $(INSTALL) -m 0644 qrouter.tcl $(DESTDIR)${LIBINSTALL}
+
+ uninstall:
+diff --git a/qrouter.sh.in b/qrouter.sh.in
+index 12bab42..8e7cbda 100755
+--- a/qrouter.sh.in
++++ b/qrouter.sh.in
+@@ -57,7 +57,7 @@ shift
+
+ if [ $TKCON ]; then
+
+- exec ${loclibdir}/tkcon.tcl \
++ exec /usr/bin/tkcon \
+ -eval "source ${loclibdir}/console.tcl" \
+ -slave "package require Tk; set argc $#; set argv [list $*]; \
+ source ${loclibdir}/qrouter.tcl"