summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Eichin <eichin@thok.org>2014-06-29 15:32:39 -0400
committerMark Eichin <eichin@thok.org>2014-06-29 15:32:39 -0400
commit4a0480cc9c7493343cacbbbf15aed463fa72425d (patch)
treed76f2ad0b949b624d24089caabe8a4241ab76892
parenta6ac9286518c6f11893ec5a67153f54c554b3016 (diff)
lintian clean, 2.3.22 changes around building.HEADdebian/2.3.22master
-rw-r--r--Makefile16
-rw-r--r--debian/changelog12
-rw-r--r--debian/compat2
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules61
5 files changed, 28 insertions, 65 deletions
diff --git a/Makefile b/Makefile
index a2ce2c9..139f494 100644
--- a/Makefile
+++ b/Makefile
@@ -5,25 +5,26 @@
PROG = ratmenu
-PREFIX=/usr/local
+DESTDIR=
+PREFIX=$(DESTDIR)/usr
MANDIR=$(PREFIX)/man
OPTIMIZE ?= -O2
DEBUG ?=
WARN ?= -Wall -pedantic
-CC = gcc
LIBS = -L/usr/X11R6/lib -lX11
-CFLAGS = $(OPTIMIZE) $(WARN) $(DEBUG)
+CFLAGS += $(OPTIMIZE) $(WARN) $(DEBUG)
$(PROG): $(PROG).c
- $(CC) $(CFLAGS) $< $(LIBS) -o $@
+ $(CC) $(CFLAGS) $(CPPFLAGS) $< $(LIBS) $(LDFLAGS) -o $@
clean:
- debian/rules clean
rm -f $(PROG)
-test: $(PROG)
+# TODO: make real tests out of these by running them under Xnest/Xephyr and
+# feeding them keystrokes, and checking their output values...
+humantest: $(PROG)
-./$(PROG) -align right foo "echo foo" bar "echo bar" menuitemsuberalle "./$(PROG) x x y y z z" exit "echo exit"
-./$(PROG) foofoofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofofooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooooo "echo foo" bar "echo bar"
-./$(PROG) f ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff fa aa aa aa aa aa
@@ -38,4 +39,5 @@ doc:
install: $(PROG)
install -D -p -m 755 -s $(PROG) $(PREFIX)/bin/$(PROG)
- install -D -p -m 755 $(PROG).1 $(MANDIR)/man1/$(PROG).1
+# ends up in *both* /usr/man and /usr/share/man, just give up here
+# install -D -p -m 755 $(PROG).1 $(MANDIR)/man1/$(PROG).1
diff --git a/debian/changelog b/debian/changelog
index 3d628c7..e17e168 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+ratmenu (2.3.22) unstable; urgency=medium
+
+ * debian/compat, debian/rules, debian/control: strip down to minimal dh
+ usage (ratmenu has *nothing* exciting about it, packaging-wise) and
+ advance to debhelper compatibility level 9. Add buildflags for hardening.
+ * Makefile: clean up PREFIX/DESTDIR/CFLAGS (hardening now works.) Move
+ tests to "humantest" since they're fundamentally interactive for now.
+ Drop manpage from install rule, since dh doesn't fix that up and we
+ end up with /usr/man *and* /usr/share/man.
+
+ -- Mark W. Eichin <eichin@thok.org> Sun, 29 Jun 2014 15:32:05 -0400
+
ratmenu (2.3.21) unstable; urgency=medium
* debian/rules: add build-arch, build-indep per Standards-Version 3.9.4.0.
diff --git a/debian/compat b/debian/compat
index 7f8f011..ec63514 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index bdf8ffb..7acdaca 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ratmenu
Section: x11
Priority: optional
Maintainer: Mark W. Eichin <eichin@thok.org>
-Build-Depends: libx11-dev, debhelper (>= 7)
+Build-Depends: libx11-dev, debhelper (>= 9)
Standards-Version: 3.9.5
Package: ratmenu
diff --git a/debian/rules b/debian/rules
index 8a79090..106987e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,58 +1,7 @@
#! /usr/bin/make -f
-#
-
-CC = gcc
-CFLAGS = -O2 -Wall
-
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
-endif
-
-LDFLAGS =
-
-SHELL = /bin/sh
-srcdir = .
-
-build:
- dh_testdir
- make CC="$(CC)" CFLAGS="$(CFLAGS)"
-
-clean:
- dh_testdir
- -rm -f ratmenu *.o
- -rm -f stamp-config stamp-build
- -rm -rf debian/tmp* debian/ratmenu/ debian/files debian/substvars
- dh_clean
-
-binary-indep:
- true
-
-DH_VERBOSE=1
-
-binary-arch:
- dh_testdir
- dh_testroot
- make -f debian/rules build
- dh_installdocs
- dh_installman
- dh_installmenu
- dh_installchangelogs ChangeLog
- dh_install
- dh_installdeb
- dh_compress
- dh_link
- dh_strip
- dh_fixperms
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-
-build-arch: binary-arch
-
-build-indep: binary-indep
-
-.PHONY: config build clean binary binary-arch binary-indep build-arch build-indep
+# lintian hardening
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+%:
+ dh $@