summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGianfranco Costamagna <locutusofborg@debian.org>2019-11-05 20:42:35 -0800
committerRuss Allbery <eagle@eyrie.org>2019-11-05 20:42:35 -0800
commit39793d479df160abcd11bc60f5e9da134c89f1bb (patch)
treeea571be28b0f1a35cd3bc48a946ee229ccabb5fb
parentbb7f41e7eec83cdb40218990f1ff2fcf888ff90c (diff)
Don't attempt to install typing for Python
Looks like typing is a Python2 package, while with Python3 it is natively supported, so that dependency has to be conditionalized for Python2 builds, or dropped since we do not provide Python2 anymore in the Debian packaging.
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/no-typing.patch14
-rw-r--r--debian/patches/series1
3 files changed, 22 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ea90a92..2dec354 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+remctl (3.16-3.1) unstable; urgency=medium
+
+ * Fix build by avoiding typing install_require (useless with python3 only
+ package) Closes: #944151
+
+ -- Gianfranco Costamagna <locutusofborg@debian.org> Tue, 05 Nov 2019 07:55:51 +0100
+
remctl (3.16-3) unstable; urgency=medium
* Fix syntax of Python autopkgtest script to work with both Python 2 and
diff --git a/debian/patches/no-typing.patch b/debian/patches/no-typing.patch
new file mode 100644
index 0000000..1a9691e
--- /dev/null
+++ b/debian/patches/no-typing.patch
@@ -0,0 +1,14 @@
+Description: Typing is native in Python3, so no need to have it specified in setup.py file, avoiding internet connection during build
+Author: Gianfranco Costamagna <locutusofborg@debian.org>
+Last-Update: 2019-11-05
+
+--- remctl-3.16.orig/python/setup.py
++++ remctl-3.16/python/setup.py
+@@ -111,7 +111,6 @@ kwargs = {
+ "description": doclines[0],
+ "long_description": "\n".join(doclines[2:]),
+ "license": "MIT",
+- "install_requires": ["typing"],
+ "setup_requires": ["pytest-runner"],
+ "tests_require": ["pytest"],
+ "classifiers": [
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..e509766
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+no-typing.patch