summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Čihař <nijel@debian.org>2017-11-11 14:27:27 +0100
committerMichal Čihař <nijel@debian.org>2017-11-11 14:27:27 +0100
commit1af008f89ee30a604de1c617c8bb9dc4dcd8bf81 (patch)
tree3cc5d317da19d3f106f46e051b51d15a4958e136
parentd824cbe0364db1d06b330862c4428772314b1c7a (diff)
Fixed compilation on architectures without MAP_POPULATE.
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/map-populate.patch17
-rw-r--r--debian/patches/series1
3 files changed, 24 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b4eef9bc..f86b958f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+rpm (4.14.0+dfsg1-2) UNRELEASED; urgency=medium
+
+ * Fixed compilation on architectures without MAP_POPULATE.
+
+ -- Michal Čihař <nijel@debian.org> Sat, 11 Nov 2017 14:27:10 +0100
+
rpm (4.14.0+dfsg1-1) experimental; urgency=medium
* New upstream release.
diff --git a/debian/patches/map-populate.patch b/debian/patches/map-populate.patch
new file mode 100644
index 00000000..e09d2ef5
--- /dev/null
+++ b/debian/patches/map-populate.patch
@@ -0,0 +1,17 @@
+Subject: Fix compation on platforms without MAP_POPULATE
+From: Michal Čihař <michal@cihar.com>
+--- a/tools/sepdebugcrcfix.c
++++ b/tools/sepdebugcrcfix.c
+@@ -154,7 +154,11 @@
+ void *map = NULL;
+ if (buf == NULL)
+ {
+- map = mmap (NULL, maplen, PROT_READ, MAP_PRIVATE | MAP_POPULATE,
++ map = mmap (NULL, maplen, PROT_READ, MAP_PRIVATE
++#ifdef MAP_POPULATE
++ | MAP_POPULATE
++#endif
++ ,
+ fd, offset);
+ if (map == MAP_FAILED)
+ {
diff --git a/debian/patches/series b/debian/patches/series
index 322ce8bd..ee8b0ef3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
+map-populate.patch
rpm-misc-man.patch
bashism.patch
lua-compat.patch