summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes 'josch' Schauer <josch@debian.org>2020-04-04 04:11:30 +0200
committerJohannes 'josch' Schauer <josch@debian.org>2020-04-04 04:11:30 +0200
commitf089315aef66361c92d1c1bd511e9e37b96dcfcd (patch)
treef66b1e48b3eb3a48c05239a69310cfcf166000b4
parentcdd7d1f831ffafb754734ec37d075933beac8afc (diff)
Fix autopkgtest (closes: #955639)
-rw-r--r--debian/changelog6
-rw-r--r--debian/tests/general8
2 files changed, 12 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ce3f937..85ede33 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+rss-bridge (2020-02-26+dfsg1-2) UNRELEASED; urgency=medium
+
+ * Fix autopkgtest (closes: #955639)
+
+ -- Johannes 'josch' Schauer <josch@debian.org> Sat, 04 Apr 2020 04:10:45 +0200
+
rss-bridge (2020-02-26+dfsg1-1) unstable; urgency=medium
* New upstream release 2020-02-26
diff --git a/debian/tests/general b/debian/tests/general
index 961b6c4..c19626b 100644
--- a/debian/tests/general
+++ b/debian/tests/general
@@ -1,9 +1,13 @@
#!/bin/sh
-set -ex
+set -exu
+
+PHPVERSION=$(phpquery -V | head -1)
rm /etc/nginx/sites-enabled/default
-cp /usr/share/doc/rss-bridge/examples/nginx.conf /etc/nginx/sites-available/rss-bridge
+sed 's/fastcgi_pass unix:\/var\/run\/php\/php[0-9.]\+-fpm.sock/fastcgi_pass unix:\/var\/run\/php\/php'"$PHPVERSION"'-fpm.sock/' \
+ /usr/share/doc/rss-bridge/examples/nginx.conf \
+ > /etc/nginx/sites-available/rss-bridge
ln -s ../sites-available/rss-bridge /etc/nginx/sites-enabled/rss-bridge
systemctl restart nginx