summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndřej Surý <ondrej@debian.org>2018-11-07 04:17:56 +0100
committerOndřej Surý <ondrej@debian.org>2018-11-07 04:17:56 +0100
commit7c6751fbb158b9599c790e41a0846749f8618d16 (patch)
tree98280b46ecfc1f021502fa4e91652acfa708aa77
parent0b7e79e286cae59ec1d349780b1beab71df79996 (diff)
parent67b8f0366d373ae697ac206b2571813a6e7afd88 (diff)
Record rss-bridge (2018-07-17-1.2) in archive suite sid
-rw-r--r--debian/changelog16
-rw-r--r--debian/control2
-rw-r--r--debian/nginx.conf.in (renamed from debian/nginx.conf)2
-rw-r--r--debian/rss-bridge.examples1
-rwxr-xr-xdebian/rules5
-rw-r--r--debian/tests/general1
6 files changed, 23 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 4bf3497..daefed4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,19 @@
+rss-bridge (2018-07-17-1.2) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Fix the nginx.conf configuration to not use hardcoded PHP version
+ (Closes: #911835)
+
+ -- Ondřej Surý <ondrej@debian.org> Wed, 07 Nov 2018 03:17:56 +0000
+
+rss-bridge (2018-07-17-1.1) unstable; urgency=medium
+
+ * Non-maintainer upload.
+ * Don't restart phpX.Y-fpm in the autopkgtests, it's not needed
+ (Closes: #911835)
+
+ -- Ondřej Surý <ondrej@debian.org> Sun, 04 Nov 2018 20:10:47 +0000
+
rss-bridge (2018-07-17-1) unstable; urgency=medium
* New upstream release 2018-07-17
diff --git a/debian/control b/debian/control
index eb74462..41d8e74 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Homepage: https://github.com/RSS-Bridge/rss-bridge
Vcs-Browser: https://browse.dgit.debian.org/rss-bridge.git/
Vcs-Git: https://git.dgit.debian.org/rss-bridge
Standards-Version: 4.1.3
-Build-Depends: debhelper (>= 11)
+Build-Depends: debhelper (>= 11), php-cli
Rules-Requires-Root: binary-targets
Package: rss-bridge
diff --git a/debian/nginx.conf b/debian/nginx.conf.in
index fb1828c..63ea8c0 100644
--- a/debian/nginx.conf
+++ b/debian/nginx.conf.in
@@ -4,7 +4,7 @@ server {
index index.php;
location /index.php {
- fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
+ fastcgi_pass unix:/var/run/php/php@PHP_VERSION@-fpm.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
diff --git a/debian/rss-bridge.examples b/debian/rss-bridge.examples
deleted file mode 100644
index d483524..0000000
--- a/debian/rss-bridge.examples
+++ /dev/null
@@ -1 +0,0 @@
-debian/nginx.conf
diff --git a/debian/rules b/debian/rules
index 5b78d80..fbc17e0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,9 +2,14 @@
%:
dh $@
+PHP_VERSION=$(shell phpquery -V | head -1)
+
override_dh_install:
dh_install
install -d -o www-data -g www-data $(CURDIR)/debian/rss-bridge/var/cache/rss-bridge
+ mkdir -p $(CURDIR)/debian/rss-bridge/usr/share/doc/rss-bridge/examples
+ sed -e 's/@PHP_VERSION@/$(PHP_VERSION)/' \
+ < debian/nginx.conf.in > $(CURDIR)/debian/rss-bridge/usr/share/doc/rss-bridge/examples/nginx.conf
override_dh_fixperms:
dh_fixperms --exclude /var/cache/rss-bridge
diff --git a/debian/tests/general b/debian/tests/general
index 14fae17..d56a7b7 100644
--- a/debian/tests/general
+++ b/debian/tests/general
@@ -7,6 +7,5 @@ cp /usr/share/doc/rss-bridge/examples/nginx.conf /etc/nginx/sites-available/rss-
ln -s ../sites-available/rss-bridge /etc/nginx/sites-enabled/rss-bridge
systemctl restart nginx
-systemctl restart php7.2-fpm
curl --silent localhost | grep '<h1>RSS-Bridge</h1>'