summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Ruderich <simon@ruderich.org>2013-12-07 18:32:55 -0800
committerRuss Allbery <rra@debian.org>2019-02-18 18:58:27 -0800
commit4ed1de1f45bc6926279430d75f3f3de8f33754e8 (patch)
tree8b8a651f0130c1b4968594db657e8c5226246032
parentb85aac193e3378d0fd757ac7143040f9959b4e3b (diff)
Honor CFLAGS/CPPFLAGS passed to configure
The CFLAGS from dpkg-buildflags are missing because they are overwritten in Makefile.am. The attached patch removes an incorrect build rule and passes the custom flags through AM_CFLAGS/AM_CPPFLAGS. All custom flags are still passed correctly. Signed-off-by: Russ Allbery <rra@debian.org> Gbp-Pq: Name 0002-Honor-CFLAGS-CPPFLAGS-passed-to-configure.patch
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c5b1a8d..57a4305 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,7 @@
## Process this file with automake to produce Makefile.in
AUTOMAKE_OPTIONS = nostdinc
-ourdefs = -DPATH_RSSH_CONFIG=\"@sysconfdir@/rssh.conf\" -DPATH_CHROOT_HELPER=\"@libexecdir@/rssh_chroot_helper\"
-ourflags = @defcflags@ @static@
-AM_CFLAGS = $(ourflags)
+AM_CPPFLAGS = -DPATH_RSSH_CONFIG=\"@sysconfdir@/rssh.conf\" -DPATH_CHROOT_HELPER=\"@libexecdir@/rssh_chroot_helper\"
+AM_CFLAGS = @defcflags@ @static@
bin_PROGRAMS = rssh
libexec_PROGRAMS = rssh_chroot_helper
nodist_rssh_SOURCES = main.c pathnames.h config.h
@@ -15,9 +14,6 @@ man_MANS = rssh.1 rssh.conf.5
EXTRA_DIST = $(man_MANS) CHROOT SECURITY LICENSE rssh.spec mkchroot.sh conf_convert.sh
base=`echo @PACKAGE_STRING@|tr " " "-"`
-.c.o:
- $(CC) -c $(DEFS) $(ourdefs) $(AM_CFLAGS) $(CPPFLAGS) $(LDFLAGS) $<
-
install-exec-hook:
chmod u+s $(libexecdir)/rssh_chroot_helper