summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2016-07-01 03:02:18 -0400
committerSean Whitton <spwhitton@spwhitton.name>2016-07-01 03:02:18 -0400
commit9fbad7fe69c5bda432983c78698d9ef62b0350e3 (patch)
tree42a12a9aba4de25eb1d54fc95c5873ff4a4fecd5 /debian
parentaf4d9aa1a6f073f6c8a58201ab42f8aae7a87712 (diff)
convert package to use dh_elpa
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog10
-rw-r--r--debian/compat2
-rw-r--r--debian/control18
-rw-r--r--debian/copyright3
-rw-r--r--debian/elpa-s.elpa1
-rw-r--r--debian/emacsen-compat1
-rw-r--r--debian/emacsen-install47
-rw-r--r--debian/emacsen-remove15
-rw-r--r--debian/emacsen-startup24
-rw-r--r--debian/install1
-rwxr-xr-xdebian/rules32
11 files changed, 30 insertions, 124 deletions
diff --git a/debian/changelog b/debian/changelog
index 882dd1a..a234856 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
-s-el (1.11.0-2) UNRELEASED; urgency=medium
+s-el (1.11.0-2) UNRELEASED; urgency=low
* Adopt on behalf of the pkg-emacsen team.
+ * Convert package build to use dh_elpa (Closes: #815304).
+ Binary package renamed s-el -> elpa-s with transitional binary package provided.
+ * Bump debhelper to compat to 10 for dh_elpa_test.
+ - Bump debhelper build dependency bound.
* Add myself as an uploader.
- * Add Vcs-* fields.
+ * Add myself to d/copyright for debian/ subdir.
+ * Uncomment & update Vcs-* fields.
+ * Bump to standards version 3.9.8 (no changes required).
-- Sean Whitton <spwhitton@spwhitton.name> Fri, 01 Jul 2016 02:15:25 -0400
diff --git a/debian/compat b/debian/compat
index ec63514..f599e28 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-9
+10
diff --git a/debian/control b/debian/control
index 9aa4589..96dfc29 100644
--- a/debian/control
+++ b/debian/control
@@ -3,16 +3,26 @@ Section: lisp
Priority: extra
Maintainer: Debian Emacs addons team <pkg-emacsen-addons@lists.alioth.debian.org>
Uploaders: Hajime Mizuno <mizuno-as@ubuntu.com>, Sean Whitton <spwhitton@spwhitton.name>
-Build-Depends: debhelper (>= 9)
-Standards-Version: 3.9.6
+Build-Depends: debhelper (>= 9.20160403), dh-elpa
+Standards-Version: 3.9.8
Homepage: https://github.com/magnars/s.el
Vcs-Git: https://anonscm.debian.org/git/pkg-emacsen/pkg/s-el.git
Vcs-Browser: https://anonscm.debian.org/cgit/pkg-emacsen/pkg/s-el.git/
-Package: s-el
+Package: elpa-s
Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, emacsen-common (>= 2.0.8), emacs
+Depends: ${misc:Depends}, ${elpa:Depends}, emacs
+Built-Using: ${misc:Built-Using}
+Recommends: emacs (>= 46.0)
+Enhances: emacs, emacs24
Description: String manipulation library for Emacs
s.el is API library to manipulate character string by Emacs Lisp.
For example, you can easily perform truncate, padding, concatenate,
remove prefix/suffix, tweak whitespace, and more functions.
+
+Package: s-el
+Section: oldlibs
+Architecture: all
+Depends: ${misc:Depends}, elpa-s
+Description: transitional dummy package, s-el to elpa-s
+ This dummy package may be safely removed.
diff --git a/debian/copyright b/debian/copyright
index 94f1f2a..4e988f0 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -7,7 +7,8 @@ Copyright: 2012 Magnar Sveen <magnars@gmail.com>
License: GPL-3+
Files: debian/*
-Copyright: 2014 Hajime Mizuno <mizuno-as@ubuntu.com>
+Copyright: (C) 2014 Hajime Mizuno <mizuno-as@ubuntu.com>
+ (C) 2016 Sean Whitton <spwhitton@spwhitton.name>
License: GPL-3+
License: GPL-3+
diff --git a/debian/elpa-s.elpa b/debian/elpa-s.elpa
new file mode 100644
index 0000000..abf136d
--- /dev/null
+++ b/debian/elpa-s.elpa
@@ -0,0 +1 @@
+*.el
diff --git a/debian/emacsen-compat b/debian/emacsen-compat
deleted file mode 100644
index 573541a..0000000
--- a/debian/emacsen-compat
+++ /dev/null
@@ -1 +0,0 @@
-0
diff --git a/debian/emacsen-install b/debian/emacsen-install
deleted file mode 100644
index ab176db..0000000
--- a/debian/emacsen-install
+++ /dev/null
@@ -1,47 +0,0 @@
-#! /bin/sh -e
-# /usr/lib/emacsen-common/packages/install/s-el
-
-# Written by Jim Van Zandt <jrv@debian.org>, borrowing heavily
-# from the install scripts for gettext by Santiago Vila
-# <sanvila@ctv.es> and octave by Dirk Eddelbuettel <edd@debian.org>.
-
-FLAVOR=$1
-PACKAGE=s-el
-
-if [ ${FLAVOR} = emacs ]; then exit 0; fi
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-#FLAVORTEST=`echo $FLAVOR | cut -c-6`
-#if [ ${FLAVORTEST} = xemacs ] ; then
-# SITEFLAG="-no-site-file"
-#else
-# SITEFLAG="--no-site-file"
-#fi
-FLAGS="${SITEFLAG} -q -batch -l path.el -f batch-byte-compile"
-
-ELDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-ELCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-ELRELDIR=../../../emacs/site-lisp/${PACKAGE}
-
-# Install-info-altdir does not actually exist.
-# Maybe somebody will write it.
-if test -x /usr/sbin/install-info-altdir; then
- echo install/${PACKAGE}: install Info links for ${FLAVOR}
- install-info-altdir --quiet --section "" "" --dirname=${FLAVOR} /usr/share/info/${PACKAGE}.info.gz
-fi
-
-install -m 755 -d ${ELCDIR}
-cd ${ELDIR}
-FILES=`echo *.el`
-cd ${ELCDIR}
-ln -sf ${ELRELDIR}/*.el .
-
-cat << EOF > path.el
-(debian-pkg-add-load-path-item ".")
-(setq byte-compile-warnings nil)
-EOF
-${FLAVOR} ${FLAGS} ${FILES}
-rm -f path.el
-
-exit 0
diff --git a/debian/emacsen-remove b/debian/emacsen-remove
deleted file mode 100644
index ca91499..0000000
--- a/debian/emacsen-remove
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/s-el
-
-FLAVOR=$1
-PACKAGE=s-el
-
-if [ ${FLAVOR} != emacs ]; then
- if test -x /usr/sbin/install-info-altdir; then
- echo remove/${PACKAGE}: removing Info links for ${FLAVOR}
- install-info-altdir --quiet --remove --dirname=${FLAVOR} /usr/share/info/s-el.info.gz
- fi
-
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-fi
diff --git a/debian/emacsen-startup b/debian/emacsen-startup
deleted file mode 100644
index 3b00a19..0000000
--- a/debian/emacsen-startup
+++ /dev/null
@@ -1,24 +0,0 @@
-;; -*-emacs-lisp-*-
-;;
-;; Emacs startup file, e.g. /etc/emacs/site-start.d/50s-el.el
-;; for the Debian s-el package
-;;
-;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
-;; Modified by Dirk Eddelbuettel <edd@debian.org>
-;; Adapted for dh-make by Jim Van Zandt <jrv@debian.org>
-
-;; The s-el package follows the Debian/GNU Linux 'emacsen' policy and
-;; byte-compiles its elisp files for each 'emacs flavor' (emacs19,
-;; xemacs19, emacs20, xemacs20...). The compiled code is then
-;; installed in a subdirectory of the respective site-lisp directory.
-;; We have to add this to the load-path:
-(let ((package-dir (concat "/usr/share/"
- (symbol-name debian-emacs-flavor)
- "/site-lisp/s-el")))
-;; If package-dir does not exist, the s-el package must have
-;; removed but not purged, and we should skip the setup.
- (when (file-directory-p package-dir)
- (if (fboundp 'debian-pkg-add-load-path-item)
- (debian-pkg-add-load-path-item package-dir)
- (setq load-path (cons package-dir load-path)))
- (require 's nil t)))
diff --git a/debian/install b/debian/install
deleted file mode 100644
index 0536e05..0000000
--- a/debian/install
+++ /dev/null
@@ -1 +0,0 @@
-s.el usr/share/emacs/site-lisp/s-el/
diff --git a/debian/rules b/debian/rules
index ce15cce..ee505f8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,32 +1,8 @@
#!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-#DH_VERBOSE = 1
-# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
-DPKG_EXPORT_BUILDFLAGS = 1
-include /usr/share/dpkg/default.mk
+export DH_ELPA_TEST_ERT_EVAL=(progn \
+ (load-file "dev/examples-to-tests.el") \
+ (load-file "dev/examples.el"))
-# see FEATURE AREAS in dpkg-buildflags(1)
-#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
-# package maintainers to append LDFLAGS
-#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
-
-
-# main packaging script based on dh7 syntax
%:
- dh $@
-
-# debmake generated override targets
-# This is example for Cmake (See http://bugs.debian.org/641051 )
-#override_dh_auto_configure:
-# dh_auto_configure -- \
-# -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
-
-
-
-
+ dh $@ --parallel --with elpa