summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-02-23 15:44:51 -0800
committerNikolaus Rath <Nikolaus@rath.org>2016-10-28 14:07:23 -0700
commit66b0572889926c1e02663340e218c079e07ab0a6 (patch)
tree59c3a1824d4d381d4fae52c26183e9907e4cbee8
parent31bf6ca63ccb06e264475729e3642d3d8c30cea7 (diff)
Ignore compiler warnings due to old Cython version
Origin: debian Forwarded: not-needed Patch-Name: ignore_cython_warnings.diff Cython versions prior to 0.24 generate Gcc compiler warnings. Since Cython 0.24 isn't in Debian yet, we ignore these warnings. Gbp-Pq: Name ignore_cython_warnings.diff
-rwxr-xr-xsetup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index ae1c00a..e2c9a21 100755
--- a/setup.py
+++ b/setup.py
@@ -111,14 +111,6 @@ def main():
compile_args = ['-Wall', '-Wextra', '-Wconversion', '-Wsign-compare']
- # Value-changing conversions should always be explicit.
- compile_args.append('-Werror=conversion')
-
- # Note that (i > -1) is false if i is unsigned (-1 will be converted to
- # a large positive value). We certainly don't want to do this by
- # accident.
- compile_args.append('-Werror=sign-compare')
-
# Enable all fatal warnings only when compiling from Mercurial tip.
# (otherwise we break forward compatibility because compilation with newer
# compiler may fail if additional warnings are added)