summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-06-27 11:25:34 -0700
committerNikolaus Rath <Nikolaus@rath.org>2018-11-06 19:40:48 +0000
commitb7128a05f30b72224e0d61046d045b1221934858 (patch)
treed0bc3843098df1a57d655970a5c49972ba2db7e0
parentbb9b22c41eea784b2ffd67b32d5296f7885fe328 (diff)
Don't hide pdflatex output.
Origin: debian Forwarded: not-needed Patch-Name: show_pdflatex_output.diff Upstream is not interested in this patch. Gbp-Pq: Name show_pdflatex_output.diff
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 93a8e52..3ea858f 100755
--- a/setup.py
+++ b/setup.py
@@ -98,9 +98,8 @@ class build_docs(setuptools.Command):
print('Running pdflatex...')
for _ in range(3):
- with open('/dev/null', 'wb') as null:
- subprocess.check_call(['pdflatex', '-interaction', 'batchmode', 'manual.tex'],
- cwd=os.path.join(dest_dir, 'latex'), stdout=null)
+ subprocess.check_call(['pdflatex', '-interaction', 'nonstopmode', 'manual.tex'],
+ cwd=os.path.join(dest_dir, 'latex'))
os.rename(os.path.join(dest_dir, 'latex', 'manual.pdf'),
os.path.join(dest_dir, 'manual.pdf'))