summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-06-27 11:25:34 -0700
committerNikolaus Rath <Nikolaus@rath.org>2018-12-28 20:04:28 +0000
commitf2b1be4cc38a0b508a43cbc115b0bda83128982e (patch)
treee959ad821ae745efe790248b1efafbde98b407f8
parent856bceab7c18c595e6fd2fca1bfaa47bf9e6d070 (diff)
Don't hide pdflatex output.
Origin: debian Forwarded: not-needed Patch-Name: show_pdflatex_output.diff Upstream is not interested in this patch. Gbp-Pq: Name show_pdflatex_output.diff
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 93a8e52..3ea858f 100755
--- a/setup.py
+++ b/setup.py
@@ -98,9 +98,8 @@ class build_docs(setuptools.Command):
print('Running pdflatex...')
for _ in range(3):
- with open('/dev/null', 'wb') as null:
- subprocess.check_call(['pdflatex', '-interaction', 'batchmode', 'manual.tex'],
- cwd=os.path.join(dest_dir, 'latex'), stdout=null)
+ subprocess.check_call(['pdflatex', '-interaction', 'nonstopmode', 'manual.tex'],
+ cwd=os.path.join(dest_dir, 'latex'))
os.rename(os.path.join(dest_dir, 'latex', 'manual.pdf'),
os.path.join(dest_dir, 'manual.pdf'))