summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolaus Rath <Nikolaus@rath.org>2016-06-27 11:25:34 -0700
committerNikolaus Rath <Nikolaus@rath.org>2018-09-02 12:48:32 +0100
commitebb646ccd7972fb28e7f1c7be9484d81b0dd394d (patch)
tree567b7304d3debbef3dac5f38ae40ee0639ec9910
parent41a30c3059626f8496962a7d0e203b37a36512d1 (diff)
Don't hide pdflatex output.
Origin: debian Forwarded: not-needed Patch-Name: show_pdflatex_output.diff Upstream is not interested in this patch. Gbp-Pq: Name show_pdflatex_output.diff
-rwxr-xr-xsetup.py5
1 files changed, 2 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 93a8e52..3ea858f 100755
--- a/setup.py
+++ b/setup.py
@@ -98,9 +98,8 @@ class build_docs(setuptools.Command):
print('Running pdflatex...')
for _ in range(3):
- with open('/dev/null', 'wb') as null:
- subprocess.check_call(['pdflatex', '-interaction', 'batchmode', 'manual.tex'],
- cwd=os.path.join(dest_dir, 'latex'), stdout=null)
+ subprocess.check_call(['pdflatex', '-interaction', 'nonstopmode', 'manual.tex'],
+ cwd=os.path.join(dest_dir, 'latex'))
os.rename(os.path.join(dest_dir, 'latex', 'manual.pdf'),
os.path.join(dest_dir, 'manual.pdf'))